Closed Bug 1507389 Opened Last year Closed Last year

Update GMP fallback downloader for Widevine CDM 4.10.1196.0

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- fixed
firefox64 --- verified
firefox65 --- verified

People

(Reporter: bryce, Assigned: bryce)

References

Details

Attachments

(2 files)

Once bug 1503124 has started serving Widevine CDM 4.10.1146.0 via our usual update service, we should also update the fallback downloader to reflect the new CDM version.

See bug 1495514 as a reference for the last time this was done.
Attaching script used to produce new file so my working can be checked.
ni in case phabricator's request slipped through the cracks.
Flags: needinfo?(rhelmer)
(In reply to Bryce Seager van Dyk (:bryce) from comment #3)
> ni in case phabricator's request slipped through the cracks.

This, and holiday travel. Thanks for the ni!
Flags: needinfo?(rhelmer)
Pushed by bvandyk@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6dc7299787ea
Update GMP fallback downloader for Widevine 4.10.1196.0 r=rhelmer
https://hg.mozilla.org/mozilla-central/rev/6dc7299787ea
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Comment on attachment 9025257 [details]
Bug 1507389 - Update GMP fallback downloader for Widevine 4.10.1196.0 r=rhelmer

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1486482

User impact if declined: Users of older Mac hardware who download the CDM via the fallback mechanism will suffer crashes when using the CDM as beta's current CDM is impacted by bug 1495751.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Low risk as we do not need any code changes in nightly to accept the new CDM. This new CDM does not change any functionality, and is intended to only address the Mac crash discussed above. We've already had the CDM baking in nightly without issue since bug 1503124 changed the balrog rules. The nightly update has been verified by QA.

Note, if uplift is approved, I intend for it to coincide with updating the balrog rules (see bug 1503124) so that beta's balrog rules and fallback downloader are in-step. However, these two updates do not need to happen at the exact same time and if either happens before the other, even by a matter of days, that is not a problem and does not present risk.

String changes made/needed: None
Attachment #9025257 - Flags: approval-mozilla-beta?
Comment on attachment 9025257 [details]
Bug 1507389 - Update GMP fallback downloader for Widevine 4.10.1196.0 r=rhelmer

[Triage Comment]
Widevine CDM stability fix for older Macs. Approved for 64.0b13.
Attachment #9025257 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Hi,

The feature is implemented both on the latest Beta 64.0b13 Build ID:20181126173133 and Nightly 65.0a1 Build ID:20181127220131, checked on Win10 x64 and macOS 10.11. Marking as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9025257 [details]
Bug 1507389 - Update GMP fallback downloader for Widevine 4.10.1196.0 r=rhelmer

[ESR Uplift Approval Request]

If this is not a sec:{high,crit} bug, please state case for ESR consideration: Please see bug 1518525 for justification of this request. I had hoped to have a new set of URLs by this time, but due the URLs used in this patch are our current best bet.

User impact if declined: Please see bug 1518525.

Fix Landed on Version: 65

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Small, non code change that has been landed since 65.

String or UUID changes made by this patch: None.

Attachment #9025257 - Flags: approval-mozilla-esr60?

Comment on attachment 9025257 [details]
Bug 1507389 - Update GMP fallback downloader for Widevine 4.10.1196.0 r=rhelmer

widevine cdm update for 60.5esr

Attachment #9025257 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
See Also: → 1561695
You need to log in before you can comment on or make changes to this bug.