Closed Bug 1507528 Opened Last year Closed Last year

incomplete markup view after page refresh

Categories

(DevTools :: Inspector, defect)

65 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1506792

People

(Reporter: mbalfanz, Unassigned)

References

Details

STR:
- visit https://github.com/mozilla/simulated-devices
- open the inspector and select an element in the readme, e.g. the first headline
- refresh the page with devtools open
- inspect the same element

ER:
- the markup view should show the selected element

AR:
- the markup view does not show the selected element. in fact, the markup for the "readme"-block is completely missing and only available again after closing and re-opening devtools
Just ran a mozregression on this, and the culprit points to me :)
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=631545ef79251ea54347ebcb76420b7c1c9ba333&tochange=bfb92e2d55e43b25ee6256c7a037ead4022c3f8d
So, bug 1499322 which landed in 64.
So the fix here will need to be uplifted to 64 too.
The quick fix for this is the same that I suggested in bug 1506792 actually. So those are duplicate bugs.
However, just like I said there, there is still the underlying issue of the ::after and ::before pseudo-elements not having any parentNode element when the page is refreshed. I don't understand why yet.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1506792
You need to log in before you can comment on or make changes to this bug.