Closed Bug 1507536 Opened Last year Closed Last year

Redundant right click items on the menu bar

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- unaffected
firefox65 --- verified

People

(Reporter: itiel_yn8, Assigned: mconley)

References

Details

(Keywords: regression)

Attachments

(4 files)

STR:
1. Right click the tab bar, enable Menu Bar
2. Right click the menu bar

AR:
Redundant right click items (Manage Extension, Remove Extension, Auto-Hide in Toolbar), and the items 'Pin to Overflow Menu' and 'Remove from Toolbar' are not disabled

ER:
The same as the attached "Before bug 1356920"

This is a regression from bug 1356920.
Attached image Before bug 1356920
Attached image After bug 1356920
Has STR: --- → yes
Flags: needinfo?(mconley)
Component: Tabbed Browser → Toolbars and Customization
This is a bit confusing and sloppy, but as far as I can tell, these context menu items don't actually do anything when clicked. Marking P3, but we should clean this up.
Assignee: nobody → mconley
Flags: needinfo?(mconley)
Priority: -- → P3
(In reply to Mike Conley (:mconley) (:⚙️) from comment #3)
> but as far as I can tell, these context
> menu items don't actually do anything when clicked.

Some of them actually do something:
'Manage Extension' goes to about:addons in the Get Addons tab, with an infinite 'Loading' text showing up
'Auto-Hide in Toolbar' hides the Downloads button from the toolbar
This is necessary to avoid an exception being thrown from CustomizableUI.isWidgetRemovable,
which expects all direct descendants of toolbars to either have an ID, be one of a special
set of node types, or have skipintoolbarset="true" set on it.
Depends on: 1498602
(In reply to Itiel from comment #4)
> (In reply to Mike Conley (:mconley) (:⚙️) from comment #3)
> > but as far as I can tell, these context
> > menu items don't actually do anything when clicked.
> 
> Some of them actually do something:
> 'Manage Extension' goes to about:addons in the Get Addons tab, with an
> infinite 'Loading' text showing up
> 'Auto-Hide in Toolbar' hides the Downloads button from the toolbar

Indeed, this seems quite broken.
Priority: P3 → P1
Attachment #9026806 - Attachment description: Bug 1507536 - Make sure non-customizable items in the toolbar-menubar have skipintoolbarset set to true. r?dao → Bug 1507536 - Remove spacer in toolbar-menubar, and just make the menubar items flex instead. r?dao
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd00df2e0aba
Remove spacer in toolbar-menubar, and just make the menubar items flex instead. r=dao
No longer depends on: 1498602
Duplicate of this bug: 1498602
https://hg.mozilla.org/mozilla-central/rev/fd00df2e0aba
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
LGTM. Thanks!
Status: RESOLVED → VERIFIED
Depends on: 1509711
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 65 → ---
This adds a skipintoolbarset to the toolbar-menubar spacer and the titlebar-buttonbox-container
hbox to avoid a case where an exception can be thrown from CustomizableUI.isWidgetRemovable,
which expects all direct descendants of toolbars to either have an ID, be one of a special
set of node types, or have skipintoolbarset="true" set on it.
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d476f054342f
Set skipintoolbarset="true" on some titlebar items to avoid redundant context menu items. r=dao
https://hg.mozilla.org/mozilla-central/rev/d476f054342f
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Depends on: 1510631
Depends on: 1511106
No longer depends on: 1511106
I have reproduced this bug with Nightly 65.0a1 (2018-11-15) on Windows 7, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID 	20181203093109
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
QA Whiteboard: [bugday-20181128]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.