Closed Bug 1507537 Opened Last year Closed Last year

TEST-UNEXPECTED-FAIL | [snip]/mozmill/content-policy/test-plugins-policy.js and two more plugin tests

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 65.0

People

(Reporter: jorgk-bmo, Assigned: rjl)

Details

(Whiteboard: [Thunderbird-testfailure: Z Linux only][Thunderbird-disabled-test])

Attachments

(2 files)

TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-policy/test-plugins-policy.js | test-plugins-policy.js::test_checkPluginsInNonMessageContent
TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-policy/test-plugins-policy.js | test-plugins-policy.js::test_checkContentTab
TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-outdated.js | test-plugin-outdated.js::test_outdated_plugin_notification
TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_can_crash_plugin
TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_crashed_plugin_notification_bar
TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_crashed_plugin_notification_inline

First seen on the Nightly run on this push:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&selectedJob=211907717&revision=7e28b9f45b19f9301f26d4428bb956efbe859764

M-C last good: ca9df8b302950643ea723b66945eb224a7
M-C first bad: dca9c72df68bb59692118595dea65b78cd
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ca9df8b302950643ea723b66945eb224a7&tochange=dca9c72df68bb59692118595dea65b78cd

Also visible on a try run based on the same version:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&selectedJob=211984286&revision=01dbc444e9e0c4f6e0c2b6a87ee0914031ea05af

Log says:
https://taskcluster-artifacts.net/aTJyHuGaTd21yBkmqJYhng/0/public/logs/live_backing.log

EXCEPTION: Plugin is not turned on in content in message pane - it should be.
EXCEPTION: Plugin has been unexpectedly blocked in content tab
EXCEPTION: Plugin test taking too long
EXCEPTION: Timeout waiting for crash (three times)

Linux only, sorry guys I won't be able to fix this.
Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(geoff)
Flags: needinfo?(acelists)
Maybe noteworthy in the range:
5861cb42b71d Andrew Swan — Bug 1500265: Remove support for hybrid WebExtensions. r=kmag

Andrew, would your changes have caused any effects to plugins on Linux only?
Flags: needinfo?(aswan)
That change did not affect plugins
Flags: needinfo?(aswan)
The lines before look like a clue

/builds/worker/workspace/build/application/thunderbird/plugin-container: symbol lookup error: /builds/worker/workspace/build/application/thunderbird/libxul.so: undefined symbol: wl_surface_interface

Related of the wayland patches? 
	6fc6bdea42a6	Mike Hommey — Bug 1501218 - Enable wayland support with --enable-default-toolkit=cairo-gtk3. r=mshal
1f1eec6abd9b	Mike Hommey — Bug 1507032 - Work around bug in wayland (< 1.12) headers. r=froydnj

Would explain why it's only a linux problem.
Flags: needinfo?(mkmelin+mozilla)
First we need to verify if it's from there or not.
Or could it just require a clobber?
Clobber is a buildbot concept, it no longer exists on TC. You can try a local backout.
Ran both

make mozmill-one SOLO_TEST=content-policy/test-plugins-policy.js
make mozmill-one SOLO_TEST=content-tabs/test-plugin-crashing.js 

... locally. But the tests all pass there.
And so does 
make mozmill-one SOLO_TEST=content-tabs/test-plugin-outdated.js
But then again, I don't get the "undefined symbol: wl_surface_interface" errors either.
The try is 100% green, so this is caused by one of these two:
6fc6bdea42a6 Mike Hommey - Bug 1501218 - Enable wayland support with --enable-default-toolkit=cairo-gtk3. r=mshal
1f1eec6abd9b Mike Hommey - Bug 1507032 - Work around bug in wayland (< 1.12) headers. r=froydnj

Mike, these changes but some of out MozMill tests. What needs to be done to fix the bustage?

Please note comment #3 where Magnus spotted this in the logs:
/builds/worker/workspace/build/application/thunderbird/plugin-container: symbol lookup error: /builds/worker/workspace/build/application/thunderbird/libxul.so: undefined symbol: wl_surface_interface
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(geoff)
Flags: needinfo?(acelists)
Let's add our build man here as well.
Flags: needinfo?(rob)
There is something definitely wrong with the libmozwayland library as it is in your build. Compare:

0000000000000000 g    DO *ABS*	0000000000000028  Base        wl_surface_interface

with how it is in Firefox's:

0000000000005028 g    DO .bss	0000000000000028  Base        wl_surface_interface
Flags: needinfo?(mh+mozilla)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/fa82003e8d33
disable failing plugin tests on Linux. rs=bustage-fix
Putting a milestone so we know when that got landed.
Target Milestone: --- → Thunderbird 65.0
You're not using the right version of binutils. Which looks like is due to you not having the binutils toolchain dependencies.
(In reply to Pulsebot from comment #15)
> Pushed by mozilla@jorgk.com:
> https://hg.mozilla.org/comm-central/rev/fa82003e8d33
> disable failing plugin tests on Linux. rs=bustage-fix

You're just hiding the problem, while your build *is* broken to some extent.
Essentially, it seems you need the taskcluster/ part of bug 1486998.
Thanks Mike. I'm not "hiding" the problem, I just allow for effective sheriffing. I can't click through all those failures on every push we do. We have the bug on file, NI?rjl, it's tagged, there's nothing more I can do right now.

Rob, can you port what is needed with and do a try build with https://hg.mozilla.org/comm-central/rev/fa82003e8d33 backed out.
Whiteboard: [Thunderbird-testfailure: Z Linux only] → [Thunderbird-testfailure: Z Linux only][Thunderbird-disabled-test]
On it.
Assignee: nobody → rob
Status: NEW → ASSIGNED
Flags: needinfo?(rob)
Rob, please note https://hg.mozilla.org/comm-central/rev/47991b387f8df32c9cfe4b918c742134e6b2e11c. The ported M-C bug was backed out but I left the binutils in there since they didn't cause any harm and the M-C bug will reland eventually. I guess it's not related, but just letting you know.
try is closed right now so i can't verify. just saving my work to test later.
Try run:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&selectedJob=213486160&revision=a0ef5628ca75fa7418115ad263cd472fce71f589
Complete log:
https://taskcluster-artifacts.net/QBqY2n04Thm7sDnt7qRHgg/0/public/logs//log_raw.log

The tests indicated above passed with the changes in attachment 9026920 [details] [diff] [review].

 TEST-PASS | /builds/worker/workspace/build/tests/mozmill/content-policy/test-plugins-policy.js | test-plugins-policy.js::test_checkPluginsInNonMessageContent
 TEST-PASS | /builds/worker/workspace/build/tests/mozmill/content-policy/test-plugins-policy.js | test-plugins-policy.js::test_checkContentTab
 TEST-PASS | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-outdated.js | test-plugin-outdated.js::test_outdated_plugin_notification
 TEST-PASS | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_can_crash_plugin
 TEST-PASS | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_crashed_plugin_notification_bar
 TEST-PASS | /builds/worker/workspace/build/tests/mozmill/content-tabs/test-plugin-crashing.js | test-plugin-crashing.js::test_crashed_plugin_notification_inline
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/e78f9676177c
Backed out changeset fa82003e8d33 to re-enable tests. a=backout
https://hg.mozilla.org/comm-central/rev/adf300295c5a
Port bug 1486998: Don't use gcc binutils with clang. rs=bustage-fix
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.