Closed Bug 1507637 Opened 1 year ago Closed 1 year ago

Crash in <webrender_bindings::moz2d_renderer::Moz2dBlobImageHandler as webrender_api::image::BlobImageHandler>::update

Categories

(Core :: Graphics: WebRender, defect, P3, critical)

Unspecified
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1494062
Tracking Status
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: mccr8, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-2f05646d-fe2b-4c80-bbce-96e550181115.
=============================================================

Top 10 frames of crashing thread:

0 libmozglue.dylib mozalloc_abort memory/mozalloc/mozalloc_abort.cpp:35
1 libmozglue.dylib abort memory/mozalloc/mozalloc_abort.cpp:82
2 XUL panic_abort::__rust_start_panic::abort /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libpanic_abort/lib.rs:63
3 XUL __rust_start_panic /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libpanic_abort/lib.rs:58
4 XUL std::panicking::rust_panic_with_hook /rustc/da5f414c2c0bfe5198934493f04c676e2b23ff2e/src/libstd/panicking.rs:525
5 XUL std::panicking::begin_panic libstd/panicking.rs:411
6 XUL <webrender_bindings::moz2d_renderer::Moz2dBlobImageHandler as webrender_api::image::BlobImageHandler>::update gfx/webrender_bindings/src/moz2d_renderer.rs:412
7 XUL webrender::resource_cache::ResourceCache::pre_scene_building_update gfx/webrender/src/resource_cache.rs:840
8 XUL webrender::render_backend::RenderBackend::process_api_msg gfx/webrender/src/render_backend.rs:995
9 XUL webrender::render_backend::RenderBackend::run gfx/webrender/src/render_backend.rs:738

=============================================================

Bug 1496843 landed a patch to fix this crash, but there are still some crashes in the 20181114100226 and 20181114222927 Nightlies with the same signature.

bp-f8a008a1-b953-4550-9c99-61bd30181114
assertion failed: old_reader.cache.is_empty() 

bp-971245dd-0d36-4433-915b-e09550181115
bp-7262d513-dfe0-4c47-91d5-ab1a10181115
bp-2f05646d-fe2b-4c80-bbce-96e550181115
assertion failed: old.bounds.contained_by(&dirty_rect)
Three different Google searches.

From 2 different install times for 2 builds, so maybe there's just one person who is hitting this.
So bug 1456555 introduced a problem that made this a lot more likely. Bug 1496843 fixed that problem, but the original problem likely still remains.
Priority: -- → P3
Duplicate of this bug: 1514297
STR from the dupe : 


go to http://www.bloomberg.com/dataview/2014-04-17/how-americans-die.html
click on the page once. This will start the slideshow.
Let the first one play.
Put cursor over the "men" written in blue in the body of the slide. (This is slide 1, just to make things clear)
Click on it.

CRASH
bp-a4bee91f-df11-4f39-9614-99aa10181214
> assertion failed: old.bounds.contained_by(&dirty_rect)
Crash Signature: [@ <webrender_bindings::moz2d_renderer::Moz2dBlobImageHandler as webrender_api::image::BlobImageHandler>::update] → [@ <webrender_bindings::moz2d_renderer::Moz2dBlobImageHandler as webrender_api::image::BlobImageHandler>::update] [@ ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.11760422024122218564 ] [@ ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.784231851871656785 ] [@ ?MOZ_CrashOOL@@YAXPEB…
Keywords: regression
OS: Mac OS X → All
You need to log in before you can comment on or make changes to this bug.