Closed Bug 1507644 Opened 10 months ago Closed 10 months ago

Linux artifact builds are busted on try after bug 1501218

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

No description provided.
The intent of the test is to barf at configure time when the target
system doesn't use the glibc. The reason behind this is that the setup
with the mozwayland stub library relies on the dynamic linking order
the glibc uses.

However, the test checks GLIB_LIBS, which is the result of pkg-config
--libs for *GLIB*, not glibc, and all Gtk builds use glib, irrespective
of the libc in use. Practically speaking, this means the error branch
can't ever be taken... except on artifact builds, because we don't run
pkg-config tests there.

The dynamic linking order problem only really matter when wayland is
enabled at runtime, which it isn't by default. We'll eventually have to
sort it out for tier 3 platforms, but the current moz.build doesn't do
anything for them anyways.
Ideally, artifact builds would figure out the relevant buildconfig items
that are set in the artifacts they download, such as MOZ_WAYLAND,
MOZ_UPDATER, etc.

In the meanwhile, since artifacts that are being downloaded have wayland
support, we always set MOZ_WAYLAND when doing artifact builds.

Depends on D12074
Duplicate of this bug: 1507633
Duplicate of this bug: 1507634
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/29ffc266326b
Remove dubious test in widget/gtk/moz.build. r=chmanchester
https://hg.mozilla.org/integration/autoland/rev/01a4f2502443
Always enable wayland for artifact builds. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/29ffc266326b
https://hg.mozilla.org/mozilla-central/rev/01a4f2502443
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.