Closed Bug 1507725 Opened 2 years ago Closed 2 years ago

Embed SVG from sprite with filters, defs inside symbol issue

Categories

(Core :: SVG, defect)

63 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 353575

People

(Reporter: mhogas, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.77 Safari/537.36

Steps to reproduce:

Created an svg sprite and inside added an SVG symbol, containing a <defs> tag with a gradient filter.

Example HTML code: https://codepen.io/hogash/pen/qQjKYa


Actual results:

If i embed an svg (from the svg sprite) using <use> tag, the embedded svg won't be displayed.

If however, i move the defs tag (which contains the gradient filter) upper, into the svg sprite directly, as a child, the embedded svg will be displayed.


Expected results:

The embedded icon should be displayed regardless if the defs tag (which contains the gradient filter) are inside or outside the symbol tag. 

Both scenarios here https://codepen.io/hogash/pen/qQjKYa .
Component: Untriaged → SVG
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353575
You need to log in before you can comment on or make changes to this bug.