Closed Bug 1507832 Opened Last year Closed 10 months ago

firefox-nightly with GDK_BACKEND=wayland fails to start

Categories

(Core :: Widget: Gtk, defect)

65 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jhnmlkvch9, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

launch firefox with command
GDK_BACKEND=wayland firefox


Actual results:

Attempting load of libEGL.so
IPDL protocol Error: Received an invalid file descriptor
IPDL protocol Error: Received an invalid file descriptor
Gdk-Message: 09:57:48.646: Error reading events from display: Invalid argument
Sandbox: Unexpected EOF, op 1 flags 04 path /usr/share/fonts/cantarell/Cantarell-Regular.otf%


Expected results:

firefox should have launched
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
try starting firefox normaly with xwayland, close it and open it again 

have you built in wayland support?
because only nightly 65 and up supports wayland
(In reply to Roman Stingler from comment #1)
> try starting firefox normaly with xwayland, close it and open it again 
> 
> have you built in wayland support?
> because only nightly 65 and up supports wayland

Yes, I'm using 65.0a1 (2018-11-16) (64-bit). It starts fine with xwayland. But when I force it to use wayland backend, it fails to start.
what distro do you use?

I'm using Arch and when I install it fresh and try using wayland it hangs/doesn't open a window,
although it starts firefox-bin.
When i kill the process and start it normally (xwayland) it opens fine.
after that i can close the browser and open it again via terminal or changed .desktop file with wayland backend and it popens fine.
I'm using Archlinux with SwayWM.
I was able to get it to start using wayland backend by blowing away the preferences folder (~/.mozilla)
Spoke too soon. The problem is back. Now I can't start firefox-nightly again with wayland backend.
I get the exact same error on fully up-to-date Fedora 29 / Gnome.

Infrequently, Firefox will start on pure Wayland, run for several minutes, then hang. But almost every time, it fails to start as Jonny Mako describes in the top post.

Can you please run firefox as "WAYLAND_DEBUG=1 GDK_BACKEND=wayland firefox" on terminal and see when the hangout happens? Also please attach the wayland debug output and state where the hang happens in the log. Thanks.

Flags: needinfo?(jhnmlkvch9)

This has been fixed.

Flags: needinfo?(jhnmlkvch9)

Thanks!

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.