Use long style in "last sync" date formatted

VERIFIED FIXED in Firefox 65

Status

()

enhancement
P3
normal
VERIFIED FIXED
6 months ago
4 months ago

People

(Reporter: eoger, Assigned: toms, Mentored)

Tracking

({good-first-bug})

unspecified
Firefox 65
Points:
---

Firefox Tracking Flags

(firefox65 verified)

Details

Attachments

(1 attachment)

Reporter

Description

6 months ago
How to reproduce:
Open the page action menu -> send tab to device and hover over any target.

Ryan is not happy with the short date formatting style (e.g. "Last Sync: 1 mo. ago").
This can be changed here: https://searchfox.org/mozilla-central/rev/647b9eb1099e373e079e16f147f74f3d1d65eed3/browser/base/content/browser-sync.js#725

We want the long style.
ni? :eoger to set priority on this for triage.
Flags: needinfo?(eoger)
Reporter

Updated

6 months ago
Mentor: eoger
Flags: needinfo?(eoger)
Priority: -- → P3
Assignee

Comment 2

6 months ago
Hi. I'm happy to take this one
Reporter

Comment 3

6 months ago
Hi Tom, thank you for trying to take this!
Here are some tips to get you going:
- Build instructions for Firefox Desktop are here: https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_Firefox_build
- The date formatting style can be changed at this line: https://searchfox.org/mozilla-central/rev/647b9eb1099e373e079e16f147f74f3d1d65eed3/browser/base/content/browser-sync.js#725, we want the "long" style.

I don't think there is a test covering this, but I'll trigger a try test [0] once the patch is up to make sure we don't break anything.

[0] https://wiki.mozilla.org/ReleaseEngineering/TryServer
Assignee

Comment 4

6 months ago
(In reply to Edouard Oger [:eoger] from comment #3)
> Hi Tom, thank you for trying to take this!
> Here are some tips to get you going:
> - Build instructions for Firefox Desktop are here:
> https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/
> Build_Instructions/Simple_Firefox_build
> - The date formatting style can be changed at this line:
> https://searchfox.org/mozilla-central/rev/
> 647b9eb1099e373e079e16f147f74f3d1d65eed3/browser/base/content/browser-sync.
> js#725, we want the "long" style.
> 
> I don't think there is a test covering this, but I'll trigger a try test [0]
> once the patch is up to make sure we don't break anything.
> 
> [0] https://wiki.mozilla.org/ReleaseEngineering/TryServer

Thanks Edouard. I've built the latest nightly. I'll get started on this soon.
Assignee

Comment 5

6 months ago
Ok I've rebuilt it with the long formatting and it looks fine. Instead of "23 mins ago" it says "23 minutes ago"
Assignee

Comment 6

6 months ago
Here's the bug I filed for commit access.

https://bugzilla.mozilla.org/show_bug.cgi?id=1510541
Assignee

Comment 7

6 months ago
(In reply to Edouard Oger [:eoger] from comment #3)

> I don't think there is a test covering this, but I'll trigger a try test [0]
> once the patch is up to make sure we don't break anything.
> 
> [0] https://wiki.mozilla.org/ReleaseEngineering/TryServer

Hey Ed, can you give me a hand in committing the changes? I'm a noob here so I'm having trouble working out the procedure.
Reporter

Comment 8

6 months ago
I think with the level 1 access you have you can use phabricator:
https://moz-conduit.readthedocs.io/en/latest/phabricator-user.html#user-guide

If not, you can simply `hg export` your commit and attach it to this bug (might be easier since it's a fairly small patch).
Assignee

Comment 9

6 months ago
Changed format style in "last sync" date from short to long
Attachment #9029181 - Attachment description: y# Enter a commit message. # # Changes: # # browser/base/content/browser-sync.js → Bug 1507836 - Use long style in "last sync" date formatted
Reporter

Updated

6 months ago
Assignee: nobody → causality1
Status: NEW → ASSIGNED

Comment 11

6 months ago
Pushed by eoger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fb9b6c366557
Use long style in "last sync" date formatted r=eoger
Reporter

Comment 12

6 months ago
Thank you for taking this Tom and great job!
I have requested your patch to be pushed to autoland, your changes should appear in Firefox Nightly very soon.

Comment 13

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fb9b6c366557
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: qe-verify+

I have managed to reproduce the issue using Fx65.0a1 buildID: 20181116220054.

The issue is verified fixed using Fx65.0b12 and Fx66.0a1 on windows 10 x64, ubuntu 16.04 and macOS 10.10. The 'last sync' now displays the long format.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.