Set the cookie policy in the site identity panel

RESOLVED DUPLICATE of bug 1501992

Status

()

enhancement
RESOLVED DUPLICATE of bug 1501992
6 months ago
6 months ago

People

(Reporter: mwoehlke.floss, Unassigned)

Tracking

63 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

Set default cookie policy to "block".


Actual results:

Sites break and are nearly impossible to fix.


Expected results:

Site information pop-up should tell me what cookies are being blocked (for the current site) and offer to add an exception. (I'm pretty sure this used to work!) Instead, the pop-up only allows me to revoke already-granted exceptions.

Comment 1

6 months ago
(In reply to Matthew Woehlke from comment #0)
> Site information pop-up should tell me what cookies are being blocked (for
> the current site)

I suspect this would be rejected as useless to most users. I also doubt the browser can show cookies that it didn't accept.
https://developer.mozilla.org/en-US/docs/Tools/Storage_Inspector

> and offer to add an exception.

This could do with some improvement. In the latest Nightly,
1. Under about:preferences#privacy, select "Block cookies and site data" and set "Type blocked: All cookies (will cause websites to break)"
2. On a site where you need to allow cookies, click the identity button on the left side of the address bar.
3. Click the cogwheel next to "Permissions".

Actual results:
about:preferences#privacy opens with the Permissions section highlighted. There are 4 other sections between it and the Cookies and Site Data section.


The old Page Info window is significantly more useful:
1. Right-click an empty area of the page and choose View Page Info.
2. Click the Permissions icon.
3. Under "Set Cookies", uncheck "Use default" and choose between Allow, Allow for Session, or Block.
Severity: normal → enhancement
Component: Untriaged → Site Identity and Permission Panels
OS: Unspecified → All
Hardware: Unspecified → All
Summary: insanely difficult to set site cookie policy → Set the cookie policy in the site identity panel
(Reporter)

Comment 2

6 months ago
> I also doubt the browser can show cookies that it didn't accept.

It "can"... at least, it knows that a cookie request was made for the page and was rejected. (Check the console output; this is how I'd been figuring out which cookies need to be allowed.)

> The old Page Info window is significantly more useful:

Ah... maybe that's what I'm remembering. (Am I just imagining it, or did it used to be less difficult to get to that window?)

It seems like it should not be hard to add a line under 'permissions' (in the site info pop-up) that would say e.g. "cookies are being blocked for this website" with a button to change the permissions as in the page info window. For bonus points it could say how many cookies and/or expand to show what cookies.

I think the latter would be useful because lots of pages involve cookies from different domains; it's not unusual in my experience for a site to include both necessary and "legitimate" third party cookies as well as ad-related cookies. It would be helpful to have a way to pick and choose which to allow and which to (continue to) block.
It is planned (and already partially implemented) to make cookie blocking a proper part of what we now call "Content Blocking". With that, the "Turn off blocking for this site" button will also override the cookie preferences and we will list all blocked and loaded cookies (or rather the hosts) in the control center.

Duping to bug 1501992 as a representative of that work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1501992
You need to log in before you can comment on or make changes to this bug.