Move dispatch-to-STS logic into MediaTransportHandler

RESOLVED WONTFIX

Status

()

enhancement
P2
normal
Rank:
19
RESOLVED WONTFIX
5 months ago
a month ago

People

(Reporter: bwc, Assigned: bwc)

Tracking

(Blocks 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Assignee)

Description

5 months ago
We want to present the same API surface regardless of whether the underlying implementation uses STS or IPC.
(Assignee)

Updated

5 months ago
Assignee: nobody → docfaraday
(Assignee)

Comment 2

5 months ago
It looks like this will afford an opportunity to really clean up the threading model for the signaling side as well.

Updated

5 months ago
Rank: 20
Priority: -- → P2

Updated

5 months ago
Rank: 20 → 19
(Assignee)

Updated

5 months ago
Attachment #9025792 - Attachment is obsolete: true

Updated

5 months ago
Duplicate of this bug: 1499379

Updated

5 months ago
Duplicate of this bug: 1506884
Blocks: socket-proc-webrtc
No longer blocks: socket-proc
Attachment #9026177 - Attachment is obsolete: true

Updated

5 months ago
Blocks: 1499796

There are some r+ patches which didn't land and no activity in this bug for 2 weeks.
:bwc, could you have a look please?

Flags: needinfo?(docfaraday)
(Assignee)

Comment 28

a month ago

Unfortunately, this stuff is going to have to be re-thought.

Status: NEW → RESOLVED
Last Resolved: a month ago
Flags: needinfo?(docfaraday)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.