Closed Bug 150804 Opened 21 years ago Closed 21 years ago

keywords should default to all

Categories

(Bugzilla :: Query/Bug List, defect)

2.17
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: timeless, Assigned: endico)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

the top n items in the search page are AND ops, *except* for keywords

what you see:
Summary: contains all of the words/strings
A comment: contains all of the words/strings
The URL: contains all of the words/strings
Whiteboard: contains all of the words/strings
Keywords: contains any of the keywords

what you should see:
Summary: contains all of the words/strings
A comment: contains all of the words/strings
The URL: contains all of the words/strings
Whiteboard: contains all of the words/strings
Keywords: contains all of the keywords
I don't think this is fixed in the 'official' default params
Depends on: 150783
Is this really a regression?  Didn't keywords default to "any" in 2.14?
Yeah, this isn't a regression.

Changing this needs to be part of the all vs any vs some for multiple things
discussion.
No longer depends on: 150783
*** Bug 152965 has been marked as a duplicate of this bug. ***
Depends on: 150783
Keywords: regression
Come on! This is a regrssion!!

In old days, I can just type in "perf, regression" in keyword field, and I get a
list of performance regression bugs.  Now, I'm getting a huge list of 997 bugs,
which has bugs that are "perf" issues but not regressions, or "regression" not
even related to performance.  This bug list take a lot longer to generate and
query becomes useless.

We need to fix it so that bugs contains both "perf" AND "regression" shows up,
and this should also work for bugs that have keywords more than specified,
meaning a bug with "perf, regression, nsbeta1, mozilla1.0" should also show up
on the query list.

I'd appreciate it, if this can be addressed soon.  Thanks!!!
myk, your thoughts?


I'm not fussed either way, really. This would jut involve changing the default
query param
Cathleen knows better than me.  If she says this is a regression, it is, unless
someone else knows differently.  Sounds like changing it also helps performance.
 I just changed it on b.m.o., but I'll leave the bug open for a Bugzilla fix.
Blocks: 150783
No longer depends on: 150783
This patch moves "all keywords" up above "any keywords" in the list so it gets
selected by default.  This order is also consistent with the order of the query
terms for the fields above the keywords field.
Attachment #88955 - Flags: review+
Hmm, if this is a regression, it should be on the 2.16 train.
Target Milestone: --- → Bugzilla 2.16
Comment on attachment 88955 [details] [diff] [review]
patch v1: one way to fix the problem

This isn't a regression from my 2.14 build, but I think that allwords is
probably a better default.

r=bbaetz
Attachment #88955 - Flags: review+
Checking in template/en/default/search/form.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/form.html.tmpl,v 
<--  form.html.tmpl
new revision: 1.2.2.3; previous revision: 1.2.2.2
done


Checking in template/en/default/search/form.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/form.html.tmpl,v 
<--  form.html.tmpl
new revision: 1.6; previous revision: 1.5
done
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.