WebRender breaks extensions' pop-up panels

VERIFIED FIXED in Firefox 65

Status

()

defect
P2
major
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: tgnff242, Assigned: sotaro)

Tracking

(Blocks 1 bug, {nightly-community, regression})

Trunk
mozilla65
Unspecified
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

1. Create a new profile (not sure if Linux is necessary).
2. Set gfx.webrender.all to true and restart the browser.
3. Install an extension which adds an icon that triggers a pop-up panel (eg. Containers [1]).
4. Try to interact with the pop-up panel.

[1]: https://addons.mozilla.org/en-US/firefox/addon/multi-account-containers


Actual results:

Hovering over the elements does nothing. Clicking on them activates them, but it's only visible after you close and open again the panel, which breaks completely extensions like translators that need to update the panel with the translated word [2].

[2]: https://addons.mozilla.org/en-US/firefox/addon/simple-translate


Expected results:

It should work as good as when WR is disabled.

Bisections points to Bug 1506767.

mozregression log:
 8:12.67 INFO: No more inbound revisions, bisection finished.
 8:12.67 INFO: Last good revision: 241738774bb1b1f998770af0e0dd82c6ba8de36d
 8:12.67 INFO: First bad revision: 896d672ed0abaece6317543d2d14783044c2709a
 8:12.67 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=241738774bb1b1f998770af0e0dd82c6ba8de36d&tochange=896d672ed0abaece6317543d2d14783044c2709a
(Reporter)

Updated

5 months ago
Blocks: 1506767
Has Regression Range: --- → yes
Has STR: --- → yes
(Assignee)

Updated

5 months ago
Assignee: nobody → sotaro.ikeda.g
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Duplicate of this bug: 1508124
Severity: normal → major
OS: Unspecified → All
Priority: -- → P2
GTX1060, KDE, Debian Testing
Same regression range: If you drag a tab out of the window, the new window's web content is often just blank. Same when dragging it back.
(Assignee)

Comment 3

5 months ago
Sorry, it was caused by my silly mistake :(
(Assignee)

Updated

5 months ago
Attachment #9025975 - Flags: review?(matt.woodrow)
Attachment #9025975 - Flags: review?(matt.woodrow) → review+

Comment 5

5 months ago
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/20c99b0e8e4e
Fix mAsyncImageManager->AddPipeline() calls in WebRenderBridgeParent::UpdateWebRender() r=mattwoodrow

Comment 6

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/20c99b0e8e4e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
(Reporter)

Comment 7

5 months ago
I verified the fix on Nightly with Build ID 20181119100448.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.