Since yesterday, google search engine input box does not work properly because of bad browser sniffing

REOPENED
Unassigned

Status

REOPENED
4 months ago
a month ago

People

(Reporter: pe1chl, Unassigned)

Tracking

Firefox 60

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4

Steps to reproduce:

Visit the wellknown www.google.com to search the internet


Actual results:

The cursor in the input field appears too small and too high, and when typing the input the font is incorrect and autocompletion fields appear at the wrong location.



Expected results:

Operation as before.  Firefox on the same machine still works OK.
(Reporter)

Comment 1

4 months ago
Tried disabling Adblock+ and Ghostery because they might block some CSS but there was no difference (after shift-reload)
This is a google problem. They do invalid browser sniffing. It has been reported already but they will likely not care. You can cirumvent it by setting a standard Firefox user agent for google.

http://forums.mozillazine.org/viewtopic.php?p=14808162#p14808162
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → INVALID

Comment 3

4 months ago
Perhaps this issue can be reopened and reassigned to Tech Evangelism->Desktop.  The product description still indicates that it is "For reporting web pages that need to be upgraded to support web standards and Gecko-based browsers", which definitely covers SeaMonkey.  Assign it to me if desired; I'm one of the people who has reported the problem and am monitoring the above-noted mozillaZine Forums thread in case anyone else reports the "correct" (i.e., on Google's end) solution.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
Component: General → Desktop
Product: SeaMonkey → Tech Evangelism
Summary: Since yesterday, google search engine input box does not work properly → Since yesterday, google search engine input box does not work properly because of bad browser sniffing
Version: SeaMonkey 2.49 Branch → Firefox 60
Duplicate of this bug: 1509662

Comment 5

4 months ago
I did some experimenting with the useragent string and google.com. It seems that Google checks the SeaMonkey version number, and assumes the same numbering as Firefox. "Firefox/21.0" and before gives the bad formatting reported here. Google seems to do the same for "SeaMonkey/21.0" and before, which includes the current version "SeaMonkey/2.49.4". Eg. the following give the incorrect formatting:

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.4
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/21.0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/21.0

but the following look good:

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/22.0
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/52.0

For completeness, I get correct, but old-style formatting, if I remove Firefox-compatibility, eg. with:

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 SeaMonkey/2.49.4

Has this bug already been reported to Google? Is it worth adding this more specific information?

Thanks,
Tim.

Comment 6

4 months ago
(In reply to Tim Adye from comment #5)
> Has this bug already been reported to Google? Is it worth adding this more
> specific information?

I reported the problem using the "Send feedback" link at the bottom of the search results page.  I haven't received a response (yet).  I think your extra information is helpful and would encourage you to report it as well.  Besides the "Send feedback" form, there is also a Google Search Help Forum at <https://productforums.google.com/forum/#!forum/websearch> and it seems there is already an active discussion about the issue at <https://productforums.google.com/forum/#!topic/websearch/7ED-qV__XCc;context-place=topicsearchin/websearch/seamonkey>.  If your info isn't already there, you might want to add it to the thread.

Comment 7

4 months ago
I also told Google in its searhc forum and feedback, and got nothing. It doesn't seem like Google cares about non-popular web browsers like SeaMonkey. Do leave comments and feedbacks to Google. It's not Mozilla and SeaMonkey's faults.

Comment 8

4 months ago
Also as a workaround, you can disable SM's user agent string option not to advertise Firefox compability as shown in my uploaded https://image.ibb.co/emUTn0/Disable-UAstring-Advertise-Firefox-Compatbility.gif screen capture/shot. No need to hack or do anything special until Google fixes it if they ever do so.
(Reporter)

Comment 9

4 months ago
Google is not the only one that chokes on SeaMonkey's User-Agent string.
Recently I had a problem on a Wordpress site as well.
Maybe the quality of the User-Agent parsers is falling again with reduction in browser popularity...
Remember how it was kludged in the past with things like "(compatible; " and of course the "Mozilla" at the start.
It could be time for a complete re-write of the spec... or we should give up on advertising the SeaMonkey name.

Comment 10

4 months ago
Rob, yeah. It's frustrating. This had been happening for decades for non-popular web browsers (Opera too). SeaMonkey isn't alone. Oh well. That's a different topic. This is bug is about Google's user agent sniffing its own search engine for SeaMonkey web browsers so let's concentrate on that.
Duplicate of this bug: 1468114
(Reporter)

Comment 12

3 months ago
The solution could be to change the User-Agent string instead of trying to change the world.
If it would be only Google, it would in theory be possible to convince them to fix that problem.
But when it is starting to affect other products as well, it could be better to just advertise what they understand.
Maybe something like:
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
X-Real-User-Agent: SeaMonkey/2.49.4
Component: Desktop → Desktop
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.