Text clipping with WebRender on caused by snapping of transform

RESOLVED DUPLICATE of bug 1501195

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1501195
6 months ago
4 months ago

People

(Reporter: over68, Assigned: aosmond)

Tracking

(Blocks 1 bug, {regression})

65 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 wontfix, firefox66 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

6 months ago
Steps to reproduce:

1. Set gfx.webrender.all to true. Restart browser.
2. Open https://onedrive.live.com/download?cid=F96BA52A2AF70D03&resid=F96BA52A2AF70D03%211490&authkey=AFfvf3rHsms6Nms.


Actual results:

Text clipping with WebRender on.

Screenshot https://1drv.ms/u/s!AgMN9yoqpWv5i1PbtDkrC-Lyg4yd
Bug 1485420 seems a likely culprit in that range. We'll probably want to wait until Dzmitry is done the clipping rewrite before tackling this.
Blocks: 1485420

Comment 3

6 months ago
I can reproduce on Nightly65.0a1 windows10 with webrender.

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=85c0ed4ef9c07f9ed83e1279c1c0b4479881b74c&tochange=d212d02b75014a20afed1b4eb61ee80fd85a3769

Regressed by:  d212d02b7501	Jeff Muizelaar — Bug 1491130. Update webrender to commit da76f6aad61c1ba769566861ec41b42d511fa456
Blocks: 1491130
No longer blocks: 1485420
Status: UNCONFIRMED → NEW
Ever confirmed: true
No longer depends on: clipping-rewrite
Priority: -- → P3
See Also: → 1510267

The latest nightly has the big clipping rewrite. Can you still reproduce this problem on that build?

Flags: needinfo?(over68)
Reporter

Comment 5

5 months ago

I can reproduce with the latest nightly build.

Flags: needinfo?(over68)

(In reply to Alice0775 White from comment #3)

I can reproduce on Nightly65.0a1 windows10 with webrender.

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/
pushloghtml?fromchange=85c0ed4ef9c07f9ed83e1279c1c0b4479881b74c&tochange=d212
d02b75014a20afed1b4eb61ee80fd85a3769

Regressed by: d212d02b7501 Jeff Muizelaar — Bug 1491130. Update webrender
to commit da76f6aad61c1ba769566861ec41b42d511fa456

https://github.com/servo/webrender/pull/3048 might be a culprit.

(In reply to Sotaro Ikeda [:sotaro] from comment #6)

Regressed by: d212d02b7501 Jeff Muizelaar — Bug 1491130. Update webrender
to commit da76f6aad61c1ba769566861ec41b42d511fa456

https://github.com/servo/webrender/pull/3048 might be a culprit.

bug 1477625 is gecko side bug.

Blocks: 1477625
Flags: needinfo?(jmuizelaar)

Removing the 'style="transform: translateX(0px);"' seems to fix the problem. This sounds like the same kind of problem as our other snapping issues.

Flags: needinfo?(jmuizelaar)
Assignee: nobody → aosmond
Summary: Text clipping with WebRender on → Text clipping with WebRender on caused by snapping of transform
Assignee

Comment 9

4 months ago

I can confirm that the same attempted fixes as bug 1501195 resolve the issue seen in this bug as well.

Assignee

Comment 10

4 months ago

Build 20190124104034 and later contains the fix (Windows not out yet but confirmed it is fixed on Linux).

Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1501195
You need to log in before you can comment on or make changes to this bug.