Edit > Undo doesn't work to reverse message deletion/move (but Ctrl+z does work normally)

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: v.m.carr, Assigned: aceman)

Tracking

({regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

Try to use UNDO shortcut in EDIT (trl+z does work normally)


Actual results:

NOTHING


Expected results:

Folder move etc. reversed
Assignee: moz_en-gb → nobody
Component: en-GB / English (United Kingdom) → Untriaged
Product: Mozilla Localizations → Thunderbird
QA Contact: moz_en-gb
Which undo shortcut, the one on the context/right-click menu? Seems to work for me.
Yes the one in the context/right-click menu.  Still doesn't work with the latest beta update 64.0b3 (today)
Sorry, using this beta I can't reproduce this. I did this:

Write a new message, type something, right-click, context menu shows, type u for undo. Test disappears, that is, undo works.

Try with add-ons disabled, see help menu.
Tried with add-on disabled. N effect context menu undo still doesn't work
Alice, can you reproduce?
Flags: needinfo?(alice0775)
Works for me in compose window.


But, "Undo Delete Message", "Undo Move Message" stops working!

For example:
1. Right click on a message in List View
2. Choose "Delete Message"
  --- deleted as expected
3. Edit > Undo Delete Message
  --- Does Nothing, BUG!


Regression Window:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=9c6c4038b3b5ab074c1d9c2bf91bae0a062adaab&tochange=89435f04afee556e91d8f17634cd377dff5ac8d2
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b4aeb99d1cb601e5a5288ca05630913fa8528a1c&tochange=6862624e24d005fb4f8fb07c6800d2acef1d287e
Flags: needinfo?(alice0775)
Thanks. Well, it would be bug 1446609. BTW, Ctrl+Z does bring the deleted message back.

Aceman, could you please take a look, preferably in a new bug.
Flags: needinfo?(acelists)
Posted patch 1508210.patchSplinter Review
Yes, the cmd_undo and cmd_redo commands didn't get their oncommand= moved from the removed overlay in bug 1446609 in a similar way that the other commands like cmd_cut did in https://hg.mozilla.org/comm-central/rev/6bea4bcfa60f#l12.126 .
Assignee: nobody → acelists
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(acelists)
Attachment #9029064 - Flags: review?(jorgk)
Blocks: 1446609
Component: Untriaged → Mail Window Front End
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → All
Target Milestone: --- → Thunderbird 65.0
Version: unspecified → 61
Summary: UNDO shortcut doesn't work but ctrl+z does work normally in latest Thunderbird → Edit > Undo doesn't work to reverse message deletion/move (but Ctrl+z does work normally)
Comment on attachment 9029064 [details] [diff] [review]
1508210.patch

Thanks.
Attachment #9029064 - Flags: review?(jorgk)
Attachment #9029064 - Flags: review+
Attachment #9029064 - Flags: approval-comm-beta+
Sorry this is way beyond my ability to make a comment or even observation
No problem, we think we found the cause of the problem and it should be fixed in tomorrow's daily build.
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/0663b3a4a657
wire up cmd_undo and cmd_redo commands again. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Comment on attachment 9029064 [details] [diff] [review]
1508210.patch

Landed on TB 65, no further TB 64 beta.
Attachment #9029064 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.