Pane separator re-size handle missing in Message Filter window

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
7 months ago
6 months ago

People

(Reporter: schofiel, Assigned: Paenglab)

Tracking

Thunderbird 65.0
x86_64
Windows 10

Thunderbird Tracking Flags

(thunderbird_esr6064+ fixed, thunderbird64 fixed, thunderbird65 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36

Steps to reproduce:

1 Access Message Filter tool by selecting Tools - Message Filters (MF window appears)
2 Select filter name to edit
3 Select Edit (Filter Rules window appears)



Actual results:

Centre pane separator panel (labelled "Perform these actions:") is immovable due to missing re-size grip widget.

The two panes of the filter window are now equal fixed-size and do not allow modification of the display area to match contents (UI functionality modification)


Expected results:

Centre pane separator should contain re-size grip widget to allow pane re-sizing.
Reporter

Comment 1

7 months ago
Version of Thunderbird: 60.3.0 (32-bit) running on Win 10 (64-bit). This is a primarily cosmetic issue, but is a retrograde step in functionality of the UI.

Comment 2

7 months ago
Posted image resizer.png
Works for me. The resizer appears when you hover the separator.

Updated

7 months ago
Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → INVALID
Reporter

Comment 3

7 months ago
"Works for me" is not what I would expect as a response (professional or otherwise) to a bug report. I've been working in software as a developer and manager for close on 40 years now: if I had received that response to a bug report in our backlog then I would have been furious.

I assume you believe that I am making this up?

Please re-consider the change of status you have applied. 

Windows 10 Home edition (64 bit)/Thunderbird 60.3.1 (32 bit).

I have checked this again. After a reboot and re-start of Thunderbird, I get the same behaviour. Hover does **NOT** work over the centre bar of the filter window. This is a functional failure, probably due to a UI library incompatibility between 32- and 64-bit worlds.
Reporter

Comment 4

7 months ago
(In reply to Jorg K (GMT+1) from comment #2)
> Created attachment 9027363 [details]
> resizer.png
> 
> Works for me. The resizer appears when you hover the separator.

You are not verifying this on the same version of UI as I am. I would suggest you verify against a system configuration match.
Reporter

Updated

7 months ago
Status: RESOLVED → UNCONFIRMED
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Resolution: INVALID → ---

Updated

7 months ago
Flags: needinfo?(richard.marti)
Assignee

Comment 5

7 months ago
Something must have changed in toolkit. We had already bugs about the wrong cursor on horizontal splitters. When I open the inspector on the filterEditor the splitter appears.

Setting orient="vertical" shows the splitter already on opening the dialog for me.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(richard.marti)
Attachment #9027392 - Flags: review?(jorgk)
Attachment #9027392 - Flags: approval-comm-esr60?
Attachment #9027392 - Flags: approval-comm-beta?

Comment 6

7 months ago
Comment on attachment 9027392 [details] [diff] [review]
1508611-filterEditor-splitter.patch

Yes, that adds the missing splitter on trunk. However, it is already working in TB 60 ESR, but we can uplift since it won't hurt.

Maybe the reporter can attach a (small) screenshot of his panel. In my screenshot the line is clearly visible. Also, trying without add-ons (see Help menu) is an option.
Attachment #9027392 - Flags: review?(jorgk)
Attachment #9027392 - Flags: review+
Attachment #9027392 - Flags: approval-comm-esr60?
Attachment #9027392 - Flags: approval-comm-esr60+
Attachment #9027392 - Flags: approval-comm-beta?
Attachment #9027392 - Flags: approval-comm-beta+
Assignee

Comment 7

7 months ago
I don't see it on ESR60 until I use the inspector.
Keywords: checkin-needed

Comment 8

7 months ago
Hmm. Well, my screenshot is no photo-montage. Anyway, we'll get it uplifted in the next week or so.

Comment 9

7 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b75abd6ba2b3
Set orient="vertical" on splitter in filter editor to show it immediately. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 7 months ago7 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

7 months ago
Target Milestone: --- → Thunderbird 65.0

Comment 10

7 months ago
On Linux the splitter is still not seen after the patch, but that may be correct.
However, on hover the mouse cursor shows indication whether the splitter is a horizontal or vertical. It was showing horizontal before the patch, even though it could only be dragged vertically.
The patch fixes it.
Possibly the default has changed in toolkit, or the 'orient' must be set explicitly.

The same problem exists in SearchDialog.xul, please check all occurrences of <splitter> .

Updated

6 months ago
Component: Untriaged → Filters
You need to log in before you can comment on or make changes to this bug.