Closed Bug 1508636 Opened 11 months ago Closed 11 months ago

JS error on geckoview example startup

Categories

(GeckoView :: General, defect)

defect
Not set

Tracking

(geckoview64 wontfix, firefox64 wontfix, firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
geckoview64 --- wontfix
firefox64 --- wontfix
firefox65 --- fixed

People

(Reporter: kats, Assigned: mbrubeck)

References

Details

Attachments

(1 file)

Local build of GVE from latest trunk. I start it up and this goes by in the logcat:

11-20 08:32:11.144 21840-21911/? E/GeckoConsole: [JavaScript Error: "NS_ERROR_XPC_CANT_CONVERT_PRIMITIVE_TO_ARRAY: Cannot convert primitive JavaScript value into an array arg 0 [mozILocaleService.requestedLocales]" {file: "jar:jar:file:///data/app/org.mozilla.geckoview_example-2/base.apk!/assets/omni.ja!/components/GeckoViewStartup.js" line: 159}]

Points to this line:
https://searchfox.org/mozilla-central/rev/b03a62c3c82316e733a3b09622c1cb7e59f64cc3/mobile/android/components/geckoview/GeckoViewStartup.js#159
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
I haven't managed to reproduce this, but I suspect that something is passing `null` instead of the expected array here.
Pushed by mbrubeck@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2e3fcb9d7d27
Guard against setting requestedLocales to null. r=snorp,geckoview-reviewers
https://hg.mozilla.org/mozilla-central/rev/2e3fcb9d7d27
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
64=wontfix because we don't need to uplift this GVE fix.
status-geckoview64=wontfix
Product: Firefox for Android → GeckoView
Target Milestone: Firefox 65 → mozilla65
You need to log in before you can comment on or make changes to this bug.