Closed Bug 1508692 Opened 2 years ago Closed 2 years ago

Use Firefox policies instead of autoconfig for pageload tp6

Categories

(Testing :: Raptor, enhancement)

Version 3
enhancement
Not set
normal

Tracking

(firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: rwood, Assigned: rwood)

References

Details

Attachments

(1 file)

Use policies (instead of autoconfig) to install the mitmproxy cert and turn on/off the proxy. More details in Bug 1485082.

I tested Raptor tp6 with this policy and it worked great:

{
  "policies": {
    "Certificates": {
      "Install": ["/Users/rwood/.mitmproxy/mitmproxy-ca-cert.cer"]
    },
    "Proxy": {
      "Mode": "manual",
      "HTTPProxy": "127.0.0.1:8080",
      "SSLProxy": "127.0.0.1:8080",
      "Passthrough": "localhost, 127.0.0.1"
    }
  }
}
Going to implement this in both Raptor and Talos, since there is still one tp6 job running in Talos (Bug 1508694).
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/156f5b9586a6
Use Firefox policies instead of autoconfig for pageload tp6; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/156f5b9586a6
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Blocks: 1514451
Duplicate of this bug: 1485082
You need to log in before you can comment on or make changes to this bug.