Closed Bug 1508702 Opened 9 months ago Closed 9 months ago

[WIN] Dropdown buttons in about:addons plugins section expand width when tab-clicked

Categories

(Toolkit :: Add-ons Manager, defect, P1, minor)

63 Branch
All
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: cfogel, Assigned: Paolo)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
- 63.0b3, 64.0b10, 65.0a1 (2018-11-20)  

[Affected platforms]:
- win10x64

[Steps to reproduce]:
1. Launch Firefox;
2. Access  about:addons
3. Click on the Plugins section;
4. Press the TAB key until [Ask to activate] is brought into focus;
5. Click on that button;
6. Click on any plugin from the list;

[Expected result]:
- the dropdown menu is displayed properly;

[Actual result]:
- the button expands a few pixels on tab_focus;
* steps 4-5: the Options button is pushed to the left;
- issues encountered for the buttons with this format(in both sections at step 4 and 6)

[Regression range]:
- checking for regression I considered the width issue as bad for the button at step 6, in between there where versions in which the buttons on steps 4-5 appeared to not have this issue;
- bug 1498632 appears to be at fault;


[Additional notes]:
- attached screen capture with issue;
- issue is best visible for steps 4+5;
- macOS(10.13) and Ubuntu(16.04) are not affected by this issue;
- around 63.0a1(20180801223951) the text shifted on clicks, but that might be intended for UX;
Hey Emilio, mind confirming if this is the case?
Thank you!
Flags: needinfo?(emilio)
Looks really unlikely given my patch affects only input[type="date"] and input[type="time"], and is a CSS-only change.
Flags: needinfo?(emilio)
Rechecked with mozregression and it had the same result.

For the buttons at steps 4-5 
- last good: 2018-10-15 changeset: 4c11ab0cd98950983cfc957f579ace6c3e918a43
- first bad: 2018-10-19 changeset: 9e9ca4e2ef17b85d0e49979049b227f3bd9915b1
when running mozregression on this issue, i land on bug 1471544 as having introduced the behaviour.
Flags: needinfo?(paolo.mozmail)
Version: Trunk → 63 Branch
Not sure why this introduced the regression, but an outline seems the right way of styling this.
Flags: needinfo?(paolo.mozmail)
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7968f626961d
Fix menulist focus outline on Windows. r=dao
https://hg.mozilla.org/mozilla-central/rev/7968f626961d
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Verified with 65.0a1 (2018-11-22) - Windows 10x64.
Issue is no longer reproducible on both the buttons from step 4 and 6.
Status: RESOLVED → VERIFIED
Did you want to request Beta approval on this, Paolo?
Blocks: 1471544
Flags: needinfo?(paolo.mozmail)
I don't know, but maybe not, given this is minor enough, and there's a small chance of styling regression somewhere else.
Flags: needinfo?(paolo.mozmail)
Fx64 RC week is next week, so let's let this ride the trains then. Thanks!
You need to log in before you can comment on or make changes to this bug.