Closed Bug 1508713 Opened 10 months ago Closed 10 months ago

Stop running "Android 4.2 x86 opt" tests

Categories

(Firefox for Android :: Testing, enhancement)

Unspecified
Android
enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox64 --- wontfix
firefox65 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(1 file)

We originally stood up the "Android 4.2 x86 opt" test platform as a smoke test for our x86 builds. The "Android 7.0 x86 opt" test platform now fills that role.

"Android 4.2 x86 opt" tests run on an old version of the android x86 emulator on aws. Execution speed is relatively slow and we have had on-going problems with the emulator becoming unresponsive. Attempts to run long-running browser tests like mochitest-plain and reftests have failed because of the emulator instability.

"Android 4.2 x86 opt" tests consist of mochitest-chrome and xpcshell tests. Neither of these suites run on "Android 7.0 x86 opt", but both of those suites run on Android 4.3 opt/debug.
Blocks: 1473368
Don't worry much about the patch itself -- I'm fine with a rubber stamp on the taskcluster details -- but I am looking for confirmation that my reasoning is correct and it is okay to stop running these tests.
Attachment #9026477 - Flags: review?(snorp)
Attachment #9026477 - Flags: review?(cpeterson)
Attachment #9026477 - Flags: review?(snorp) → review+
Comment on attachment 9026477 [details] [diff] [review]
stop running Android 4.2 x86/opt tests

(In reply to Geoff Brown [:gbrown] from comment #0)
> "Android 4.2 x86 opt" tests consist of mochitest-chrome and xpcshell tests.
> Neither of these suites run on "Android 7.0 x86 opt", but both of those
> suites run on Android 4.3 opt/debug.

SGTM
Attachment #9026477 - Flags: review?(cpeterson) → feedback+
Geoff, my GeckoView test matrix [1] says that we're still running AWSY Lite on "Android 4.2 x86 opt". Is that correct?

Your patch doesn't mention AWSY Lite. Can we stop AWSY Lite on "Android 4.2 x86 opt"? IIUC, we would then have no more tests running on "Android 4.2 x86 opt". We're still running it on "Android 4.3 (arm7) opt/debug", which should be adequate.

[1] https://docs.google.com/spreadsheets/d/17hp38bKgyLYs-ydqM0kauOgwr13ytYxh3aii6RrIBAk/edit#gid=0&range=D5
Flags: needinfo?(gbrown)
OS: Unspecified → Android
AWSY Lite is part of mochitest-chrome; by not running 4.2 mochitest-chrome, 4.2 AWSY Lite will stop running. AWSY Lite will continue on 4.3 opt/debug.
Flags: needinfo?(gbrown)
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e62a7d9b6d0c
Stop running Android 4.2 x86/opt tests; r=snorp
(In reply to Geoff Brown [:gbrown] from comment #4)
> AWSY Lite is part of mochitest-chrome; by not running 4.2 mochitest-chrome,
> 4.2 AWSY Lite will stop running. AWSY Lite will continue on 4.3 opt/debug.

Awesome!

RIP Android 4.2 x86
https://hg.mozilla.org/mozilla-central/rev/e62a7d9b6d0c
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.