Closed Bug 1508756 Opened Last year Closed Last year

Crash in nw_outbound_message_set_value

Categories

(Toolkit :: Crash Reporting, defect, critical)

65 Branch
Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1508277
Tracking Status
firefox65 --- affected

People

(Reporter: lizzard, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-550297de-cea7-42a3-a159-ab5aa0181119.
=============================================================

This was reported with 3 crashes from a single install in build 20181119100448. 


Top 10 frames of crashing thread:

0  @0x7fff6db7220a 
1 XUL google_breakpad::CrashGenerationClient::RequestDumpForException toolkit/crashreporter/google-breakpad/src/common/mac/MachIPC.mm:249
2 XUL google_breakpad::ExceptionHandler::WriteMinidumpWithException toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:382
3 XUL google_breakpad::ExceptionHandler::SignalHandler toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:628
4  @0x7fff6dd39f59 
5  @0x1489e203f 
6  @0x7fff6dad71ad 
7 AppleIntelHD3000GraphicsGLDriver AppleIntelHD3000GraphicsGLDriver@0x1f4eb 
8 AppleIntelHD3000GraphicsGLDriver AppleIntelHD3000GraphicsGLDriver@0x2bd827 
9 libsystem_network.dylib nw_outbound_message_set_value 

=============================================================
This is odd, I hope it's just a single-installation crash. The crash is originating the in the graphics driver. Looking at the breakpad code it seems that we request a dump from mach here:

https://searchfox.org/mozilla-central/rev/55895c49f55073d82d977cb74ec1d3a71ae4b25f/toolkit/crashreporter/breakpad-client/mac/crash_generation/crash_generation_client.cc#69

Then we wait for a reply here:

https://searchfox.org/mozilla-central/rev/55895c49f55073d82d977cb74ec1d3a71ae4b25f/toolkit/crashreporter/breakpad-client/mac/crash_generation/crash_generation_client.cc#77

Which calls this:

https://searchfox.org/mozilla-central/rev/55895c49f55073d82d977cb74ec1d3a71ae4b25f/toolkit/crashreporter/google-breakpad/src/common/mac/MachIPC.mm#249

Which we find at the top of the stack and which Socorro rightfully ignores. However frames 4 to 8 contain the real cause of the crash and I'm not sure why they're being skipped, maybe because they don't have symbols?
Socorro signature generation has a rule for skipping things like @0x7fff6dd39f59 which covers 4, 5, and 6 and also has a rule for skipping AppleIntelHD3000GraphicsGLDriver@ which covers 7 and 8:

https://github.com/mozilla-services/socorro/blob/c8c16fe681a698dcea690f0af23897631b745e61/socorro/signature/siglists/irrelevant_signature_re.txt#L8-L14
Also note that this is a crash via SIGABRT, which is unusual. The graphics driver must be explicitly calling `abort()`?
Given the platform, date range, stack, and OS version, this bug is likely to be a duplicate of bug 1508277. Closing as a dupe.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1508277
You need to log in before you can comment on or make changes to this bug.