scaled transparent png badly rendered

RESOLVED FIXED

Status

()

Core
ImageLib
P5
normal
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: Radek Doulik, Assigned: tor)

Tracking

({fixed1.4.2, testcase})

Trunk
All
Linux
fixed1.4.2, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments, 4 obsolete attachments)

(Reporter)

Description

15 years ago
Page with such tables is incorrectly rendered, and when you scroll down, it's
visible even more. try to browse
http://primates.ximian.com/~rodo/obrazky/aquarium/page-1.html
(Reporter)

Comment 1

15 years ago
happens with

Mozilla 1.0
Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.0.0) Gecko/20020606
(Reporter)

Comment 2

15 years ago
Created attachment 87221 [details]
example of incorrect rendering

Comment 3

15 years ago
just wondering what is the problem... what or where badly rendered area.

Updated

15 years ago
Priority: -- → P5
(Reporter)

Comment 4

15 years ago
Riscky: see the attached screenshot, image shadows are wrong (they are not part
of the image, image is without them and they are added as background images of
table cells, where some of them have col and row span > 1)
(Reporter)

Comment 5

15 years ago
Any news on this? Why do you keep it unconfirmed? Don't you experience the same
problem on http://primates.ximian.com/~rodo/obrazky/aquarium/page-1.html page?

Comment 6

15 years ago
Created attachment 88754 [details]
Incorrect rendering of PNG images with partial transparency on Windoze.

Has something to do with the transparency of the .PNG images, not the tables.
But it looks uglier on my Windoze macchine.

Comment 7

15 years ago
> Any news on this? Why do you keep it unconfirmed?
One of the reasons is that it does not have a reduced testcase. 

Comment 8

15 years ago
Created attachment 107817 [details]
testcase

this is just the shadow_e.png from the URL scaled up.  make the browser window
small enough to scroll and bad things will happen (as in the previous
screenshots)

Comment 9

15 years ago
this is probably a dupe of bug 146202, except that the URL there changed, and so
I don't really know what the problem was.  See also bug 75558, which describes
somewhat similar stuff, but it worksforME.

marking NEW
==> Imglib
Assignee: karnaze → pavlov
Status: UNCONFIRMED → NEW
Component: Layout: Tables → ImageLib
Ever confirmed: true
Keywords: testcase
QA Contact: amar → tpreston
Hardware: Macintosh → All

Updated

15 years ago
Summary: tables with colspan/rowspan badly rendered → scaled transparent png badly rendered

Comment 10

14 years ago
Retest, as it worksforme, 20030408080, W2K.
Can probably be closed.

Comment 11

14 years ago
testcase still exhibits the bug with linux trunk 20030412
might be linux-only
(Assignee)

Comment 12

14 years ago
Taking bug.
Assignee: pavlov → tor
(Assignee)

Comment 13

14 years ago
Created attachment 134988 [details] [diff] [review]
patch for linux composited image partial updates

Fix for the problem on linux.  This patch also affects the beos, xlib, and
xprint gfx platforms, none of which I'm able to test at the moment.  The
respective module owners should review/test the patch for their platforms.

Comment 14

14 years ago
Honestly, i don't see this bug in my development builds.
Maybe timeless can confirm if it exists or not in BeOS with standard gfx source.
(Assignee)

Comment 15

14 years ago
Sergei: BeOS probably wouldn't have exhibited the problem, but the fix
required changing one of the backend functions (RectStretch) that
gfx/src/beos uses.  I'm CCing the other gfx owners so they can check
to see if my untesting changes to their code break things.

Comment 16

14 years ago
tor
i compiled Mozilla for BeOS with this patch. Seems OK (as it was before).
But maybe there are some testcase for image scaling where something may be
broken with this patch? To be absolutely sure.
(Assignee)

Comment 17

14 years ago
Created attachment 135013 [details] [diff] [review]
same as previous plus win32 fix

Win32 was doing scaled composited images like this (also the OS/2 approach):
   1) read screen region and scale to size of image
   2) composite image
   3) scale back to screen region and paint

While this works for shrinking images, it gives horrible artifacts in the
background when scaling up.  This patch fixes that, though still shows some
artifacts when scrolling the test url for this bug.
Attachment #134988 - Attachment is obsolete: true
(Assignee)

Comment 18

14 years ago
Created attachment 135015 [details] [diff] [review]
plug memory leak in win32 path
Attachment #135013 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #135015 - Attachment is obsolete: true
Blocks: 176330
(Assignee)

Comment 19

14 years ago
Created attachment 135178 [details] [diff] [review]
win32: fix problem with unscaled alpha images
(Assignee)

Updated

14 years ago
Attachment #135178 - Flags: review?(pavlov)
Blocks: 75558
(Assignee)

Comment 20

14 years ago
*** Bug 75558 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 21

14 years ago
*** Bug 176330 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Attachment #135178 - Attachment is obsolete: true
Attachment #135178 - Flags: review?(pavlov)
(Assignee)

Comment 22

14 years ago
Created attachment 135336 [details] [diff] [review]
fix xprint build bustage
(Assignee)

Updated

14 years ago
Attachment #135336 - Flags: review?(pavlov)

Updated

14 years ago
Attachment #135336 - Flags: review?(pavlov) → review+
(Assignee)

Updated

14 years ago
Attachment #135336 - Flags: superreview?(bryner)
(Assignee)

Updated

14 years ago
Flags: blocking1.6b?
(Assignee)

Updated

14 years ago
Attachment #135336 - Flags: approval1.6b?
Attachment #135336 - Flags: superreview?(bryner) → superreview+

Comment 23

14 years ago
Comment on attachment 135336 [details] [diff] [review]
fix xprint build bustage

a=asa (on behalf of drivers) for checkin to Mozilla 1.6 beta
Attachment #135336 - Flags: approval1.6b? → approval1.6b+
(Assignee)

Comment 24

14 years ago
Checked in.  Leaving bug open for os/2 work.

Comment 25

14 years ago
tor,
BeOS build is broken.
RectStretch() 
at line 498 in nsImageBeOS lacks arguments.
(while RectStretch at 478 has full set of them.)
(Assignee)

Comment 26

14 years ago
BeOS bustage fix checked in.
The "testcase" attachment above, the test case that I posted recently to bug
#75558, and the "exteeeemely stretched" example attached to bug #75558 all WFM
after the checkin.

Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.6b) Gecko/20031123 Firebird/0.7+
(Mike Tigas (Nova))

Thanks!

Updated

14 years ago
Flags: blocking1.6b?
(Assignee)

Comment 28

14 years ago
Created attachment 136612 [details] [diff] [review]
fix os/2 gfx

Comment 29

14 years ago
requesting blocking 1.4.2, 
Seems to have fixed bug 220576 on Win98.
Flags: blocking1.4.2?

Comment 30

14 years ago
Comment on attachment 136612 [details] [diff] [review]
fix os/2 gfx

r=mkaply on patch
sr=blizzard
a=mkaply for 1.6
a=mkaply for 1.4.2 (I'm doing an OS/2 specific safer patch for that)
Attachment #136612 - Flags: superreview+
Attachment #136612 - Flags: review+
Attachment #136612 - Flags: approval1.6+
Attachment #136612 - Flags: approval1.4.2+

Comment 31

14 years ago
all is well.

Everything checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 32

14 years ago
re comment 30:
> a=mkaply for 1.4.2 (I'm doing an OS/2 specific safer patch for that)
Does this mean it will be fixed in 1.4.2 for os/2 only?
If there will come a 1.4.2, will it also be for other OS than OS/2, at least
Linux and Windows?

Comment 33

14 years ago
Does anyone feel a need to fix this on 1.4.2 for other platforms?

The reason I want to fix it for OS/2 is because we are still doing important
1.4.2 releases.

Comment 34

14 years ago
I need to fix this for Beonex (or rather a customer) on the 1.4 branch, but we
can do that in our own 1.4-based branch.
(Assignee)

Comment 35

14 years ago
*** Bug 231974 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 36

14 years ago
Checked in on 1.4 branch - verbal approval from mkaply.
Keywords: fixed1.4.2

Updated

14 years ago
Flags: blocking1.4.2?

Comment 37

13 years ago
This may have caused bug 250786 ("scaled gifs render as garbage") ...
You need to log in before you can comment on or make changes to this bug.