Closed Bug 1508969 Opened 1 year ago Closed 1 year ago

Improve GeckoResult Kotlin API

Categories

(GeckoView :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1463790

People

(Reporter: fluffyemily, Unassigned)

References

(Blocks 1 open bug)

Details

GeckoResult promise type requires a lot of Kotlin boilerplate code when wrapping in a coroutine. We need to improve the GeckoResult design to make this easier, or provide a Kotlin interface for an improved developer experience.
Product: Firefox for Android → GeckoView
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1463790
You need to log in before you can comment on or make changes to this bug.