[ps] Postscript contains "NO FONT WAS FOUND" which causes job not to print on HP Postscript printer

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Chris Shenton, Assigned: dcone (gone))

Tracking

Trunk
Other
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.0) Gecko/20020611
BuildID:    0000000000

The cited URL and many others I have encountered does not print. Jobs seem to
disappear.  If I tell it to Print To File, I can see there are bogus lines "NO
FONT WAS FOUND" in the output .ps file:

[...]
/Unicode2NativeDictja 0 dict def
/ja_ls {
  /NativeFont /Ryumin-Light-EUC-H def
  /UCS2Font /Courier def
  /Unicode2NativeDict Unicode2NativeDictja def
  /unicodeshow1 { real_unicodeshow } bind def
  /unicodeshow2 { real_unicodeshow_native } bind def
} bind def
%%EndProlog
 NO FONT WAS FOUND 
 NO FONT WAS FOUND 
 NO FONT WAS FOUND 
 NO FONT WAS FOUND 
 NO FONT WAS FOUND 
 NO FONT WAS FOUND 
 NO FONT WAS FOUND 
%%Page: 1 1
%%BeginPageSetup
[...]

If I remove those "NO FONT WAS FOUND" lines from the .ps file, I can print as
normal to our HP PS printer.   I'm using a normal, old style /etc/printcap
specifying a "remote" IP-connected printer with no special filters. Works fine
under old NetScape.

The generated .ps file begins like the following, indicating the postscript
module version:

%!PS-Adobe-3.0
%%BoundingBox: 18 18 558 720
%%Creator: Mozilla PostScript module (rv:1.0.0/0)
%%DocumentData: Clean8Bit
%%DocumentPaperSizes: Letter
%%Orientation: Portrait
%%Pages: (atend)
%%PageOrder: Ascend
%%EndComments
% MozillaCharsetName: iso-8859-1

This "NO FONT WAS FOUND" problem occurs on plenty of other pages as well, but
it's too early for me to tell if it happens on ALL pages visited. 


Built on x86 running FreeBSD-4.6-RC from source, happened in both code bases: 

mozilla-source-1.0rc3.tar.bz2 (May 26)
mozilla-source-1.0.tar.bz2 (May 31)

Reproducible: Always
Steps to Reproduce:
1. Go to cited URL
2. Do a PRINT, watch nothing happen (I think printer rejects the job)
3. Do a PRINT TO FILE, see NO FONT WAS FOUND line, remove them, send job to
printer normally, watch it print

Actual Results:  File has NO FONT WAS FOUND lines. 
Removing them manually then doing "lpr /tmp/yahoo.ps" prints fine.

Expected Results:  Not generated the NO FONT WAS FOUND lines which irritate the
printer.

Comment 1

16 years ago
I see something quite similar using the Solaris5.7 binary downloaded from
mozilla.org.

In my case, the NO FONT WAS FOUND message is also appearing to be written to
stderr (or at least some file descriptor that corresponds to the terminal
emulator where mozilla was initiated.

The strange thing here is that _some_ pages do print.  I've not found a pattern
to what does and does not print, which means that things are pretty frustrating.

Comment 2

16 years ago
sounds like a dup
Assignee: rods → dcone
hm... dup of what?
Whiteboard: DUPME

Updated

16 years ago
Summary: Postscript contains "NO FONT WAS FOUND" which causes job not to print on HP Postscript printer → [ps] Postscript contains "NO FONT WAS FOUND" which causes job not to print on HP Postscript printer

Comment 4

16 years ago
Mozilla 1.0 on RH6.2 with truetype fonts gives repeated "NO FONT WAS FOUND" on
stderr when printing from most sites. The pages turns out ok on a HP LJ 4100. If
I change the font settings to non-true-type, and checks the box for "Allow
documents to use other fonts" the messages disappear. Could these messages be
coming from ghostscript because it does not have the true-type fonts used?

Comment 5

16 years ago
Created attachment 97045 [details]
A simple HTML file that does not print

This seems to be the simplest HTML file does not print.
The problem seems to be the 
<font face="Times New Roman">TEXT</font>
construct.

Comment 6

16 years ago
I created an attachment (see above) that does not print
using Mozilla 1.0 or Mozilla 1.1 under MacOS X 10.1.5.
Symptoms:
  When you select File->Print, the print dialog box pops
  up, and you can click Print.  However, nothing happens
  after that.  You can't print to files, not even postscript.

I am pretty sure this is the same bug as the one reported
above, since I can't print the URL given either, and the
URL given contains <font face...> constructs.

Comment 7

15 years ago
Chris, are you still experiencing this problem? There are several other reports
about the "NO FONT WAS FOUND" message (mostly old reports) but this seems to be
the only one reporting the text within the postscript output.

Comment 8

15 years ago
No response from the reporter. Resolving WFM. Chris, if you can reproduce this
with a current copy of mozilla, please feel free to reopen the report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.