Some params containing mail-templates contain URLs with terminating punctuation

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
User Accounts
--
trivial
RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: gerv, Assigned: Shane H. W. Travis)

Tracking

unspecified
Bugzilla 2.20
Bug Flags:
approval +

Details

Attachments

(1 attachment)

Some mailers are not smart enough to correctly linkify:

Use the Bugzilla Helper to submit bugs:
http://www.mozilla.org/quality/help/bug-form.html.

and linkify the trailing period. We should add spaces before any trailing
periods. This is definitely a problem on b.m.o's customised version (where I got
the original report from - thanks to paul@pgoelz.com), and may also be a problem
in the trunk.

Gerv
(Assignee)

Comment 1

14 years ago
I only see one place where there is punctuation after a URL in the trunk, and 
that's in the default 'whinemail' parameter. 

I will fix this for the trunk; am setting the bug to block the bmo-upgrade bug 
so that Dave knows to check for this issue in customized bmo templates the next 
time he updates.
Assignee: myk → travis
Severity: normal → minor
Summary: New account mail URLs have terminating full stops. → Some params containing mail-templates contain URLs with terminating punctuation
(Assignee)

Updated

14 years ago
Blocks: 280371
(Assignee)

Comment 2

14 years ago
Created attachment 175324 [details] [diff] [review]
Code patch for tip

About as simple as a patche can be...
Attachment #175324 - Flags: review?(timeless)

Updated

14 years ago
Attachment #175324 - Flags: review?(timeless) → review+
(Assignee)

Updated

14 years ago
Severity: minor → trivial
Status: NEW → ASSIGNED
Flags: approval?
Target Milestone: --- → Bugzilla 2.20
OK, this doesn't appear to be an issue on bmo currently except for the one
travis found.  The URL to the Bugzilla Helper changed, and the period was
removed when the link was changed in the password mail.
No longer blocks: 280371
Flags: approval? → approval+
(Assignee)

Comment 4

14 years ago
[14:02] <travis> 150901 was, perhaps, the simplest bugfix I shall ever do: 
[14:02] <travis> I removed one period from one line of code.
[14:02] <travis> (Is there a category below 'trivial'?)

Checking in defparams.pl;
/cvsroot/mozilla/webtools/bugzilla/defparams.pl,v  <--  defparams.pl
new revision: 1.148; previous revision: 1.147
done
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.