Menus display only to the right, will go offscreen...

VERIFIED DUPLICATE of bug 9454

Status

P1
normal
VERIFIED DUPLICATE of bug 9454
19 years ago
14 years ago

People

(Reporter: laurel, Assigned: mikepinkerton)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using 1999092809m11 on linux 6.0, NT 4.0 and mac OS 8.51

Menus will only display to the right and will not adjust leftward if running off
the edge of the sreen.

A great example:
When using the File/Copy message hierarchichal menus, submenus will run
offscreen to the right.  This can happen if you have several sublevels of folder
structure(s) or if the window is in a restored state and moved so the menu
starts cascading to the right edge of the screen.  In all platforms in 4.x, the
(sub)menu which can not be fully displayed to the right within the current
screen viewing area will adjust and display to the left so the user can see the
full menu display.

1.  In messenger window, open Inbox and select a message.
2.  Resize window and move it so the main menu item Message is fairly close to
the right edge of the screen.
3.  Pull down the Message menu and select Move Message or Copy message.
Result:  The menu runs offscreen to the right, hiding some or all of contents.
Particularly hard to deal with if you're using Move or Copy with a large
subfolder hierarchy.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel
(Reporter)

Comment 1

19 years ago
Oops, mistake ... doesn't happen on the mac, just windows and linux.

Updated

19 years ago
Assignee: phil → saari

Comment 2

19 years ago
Reassign to saari

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

19 years ago
Blocks: 11091

Comment 3

19 years ago
mailnews area so adding to our tracking bug.

Updated

19 years ago
Priority: P3 → P1

Comment 4

19 years ago
CCing Pav

Updated

19 years ago
Assignee: saari → pinkerton
Status: ASSIGNED → NEW

Comment 5

19 years ago
Pink is owning XPmenu positioning issues, as per the architecture meeting (see
what happens when you don't come to these pink)
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

19 years ago
*** This bug has been marked as a duplicate of 9454 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Marking verified as duplicate.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.