url should not be case sensitive

VERIFIED INVALID

Status

()

Core
Networking
--
major
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Ryan Parnell, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
In testing my page I went to my local URL http://192.168.168.71/WSS/login.asp.

I found in Mozilla 1.0 that my css and images didn't load. They work in all
other browsers include the RC 1 of mozilla which I replaced just today with 1.0.
I discovered they had become case sensitive to when I then browsed to
http://192.168.168.71/wss/login.asp - note 'WSS' is now lowercase - the CSS and
images loaded fine.

This is a huge bug and needs to be correctes ASAP since I can't predict my web
site visitors will type in the correct case!

Comment 1

16 years ago
Darin--this is invalid, correct?
Component: File Handling → Networking

Comment 2

16 years ago
URLs are and have always been case sensitive. I don't think Mozilla had this
wrong anytime in the near past, including RC1.

The testcase refuses connection, so I cannot see if there might be another problem.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 3

16 years ago
seems invalid to me.  the file path portion of a http:// URL is case sensitive.
(Reporter)

Comment 4

16 years ago
test cuz last time nothing happened.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 5

16 years ago
OK, I tried to add comments before and nothing happened so here goes again.

The reason the URL didn't work is because (I thought you'd know this ) the URL 
I gave was in the 192.168.x.x range which is a private non-routable range. I 
figured the test would be so easy to replicate I didn't bother. I'll now supply 
a test you can try.

Second, I'll give you that (I think) on UNIX boxes the URL can be case 
sensitive, but that's an operating system/web server enforcement, not a browser 
enforcement and that's how it should be. The web browser should not enforce 
case sensitivity. That's outside it's scope.

So here's a test you can try to see my point. Navigate to 
http://www.onetug.org/tocome/images/logo.gif. I get an error stating "The 
image “http://www.onetug.org/tocome/images/logo.gif” cannot be displayed, 
because it contains errors."

Now navigate to http://www.onetug.org/tocome/images/Logo.gif. For me, it 
resolves ( Mozilla build 2002053012 ). Notice the only difference is the 
capital L in logo.gif.

Try the same experiment with any other browser you wish (IE, Operah, Netscape 6 
& 4 )and it resolves both URLs, as it should. I don't think this was an issue 
with RC1, but I'd have to reinstall it to verify.

Comment 6

16 years ago
URLs are case sensitive, this has nothing to do with OS.

FWIW, both pictures work for me. But this is only a question of what the
*server* delivers.

Still INVALID.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
mass-verification of Invalid bugs.

if you don't think the report is invalid, please check to see if it has already
been reported (it might be a duplicate instead). otherwise, make sure that there
are steps (a valid test case) that clearly display the issue as an unexpected
defect.

mail filter string for bugspam: SequoiadendronGiganteum
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.