The Previous and Next arrows are changing their state when Zooming in

RESOLVED DUPLICATE of bug 1503373

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1503373
5 months ago
4 months ago

People

(Reporter: rares.doghi, Unassigned)

Tracking

(Blocks 1 bug, {regression})

Trunk
Desktop
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 disabled, firefox65 disabled, firefox66 fixed)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 months ago
Posted image PreviousAndNext.png
[Affected versions]: 
Beta 64.0b11
Nightly 65.0a1

[Affected platforms]:
Platforms: Windows 10


[Steps to reproduce]:
1. Open the Firefox and set the gfx.webrender.all to true
2. Reach http://www.playmag.fr/heroesoftomorrow and click the Ratchet and Clank tab.
3. Scroll down to the "Evolution au fil des jeux" section.
4. Play with the Zoom levels around 170% 240%. 



Expected Result:
The Previous and Next Arrows should be displayed properly.

Actual Results:
The Previous and Next Arrows are displayed as Hieroglyphs or sometimes they are not displayed at all.


This issue was reproduced on a Windows 10 using NVIDIA GeForce GT 730, NVIDIA GeForce 210 and NVIDIA GeForce GT 1030.
(Reporter)

Updated

5 months ago

Comment 1

5 months ago
I can reproduce the issue with Nightly65.0a1 Windows10 force enabled WebRender (AMD Radeon HD 6450)


STR
1. open  attached html
2. scroll to bottom until the arrow and rectangle hides under tab bar,
   Zoom in 300%,
   scroll up so that the arrow and rectangle will be in viewport
   --- observe the arrow shape

3. repeat step2 with several zoom level


Actual results:
the arrow shape collapses or not drawn.
GTX1060, KDE, Debian Testing

mozregression --good 2018-07-01 --bad 2018-11-22 --pref gfx.webrender.all:true -a https://bug1509248.bmoattachments.org/attachment.cgi?id=9026983
> 14:29.28 INFO: Last good revision: 0fcb85b4c2f2580df3de46af1c10b260dd156a44
> 14:29.28 INFO: First bad revision: f1dcdcc1674b19b6384f7354c4ac8a0f6896a1e5
> 14:29.28 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0fcb85b4c2f2580df3de46af1c10b260dd156a44&tochange=f1dcdcc1674b19b6384f7354c4ac8a0f6896a1e5

> f1dcdcc1674b	Jeff Muizelaar — Bug 1494898. Re-generate FFI header
> 85ee60997e57	Jeff Muizelaar — Bug 1494836. Replace NormalizedRect for visible area. r=mstange
> ab5269bd3c21	Jeff Muizelaar — Bug 1494898. Update webrender to commit d7a6d081384ce0da9dd359b0cf4b9f758aab1b67

https://github.com/servo/webrender/compare/0d2e9611c07e04ac830277f16a3b46bf125b9e7c...d7a6d081384ce0da9dd359b0cf4b9f758aab1b67

It caused two other regressions: bug 1496019, bug 1501111
Keywords: regression
OS: Windows 10 → All
Priority: -- → P3
WebRender isn't scheduled to ship to all users in 64 so fix-optional for 64.
I cannot repro this anymore, is this still happening?
Oh, I see, I misunderstood the STR. I can repro indeed, thanks!

Also, having the reduced test-case is immensely helpful, thanks Alice!
STR: Scroll down, zoom in, scroll up.

Reproducible with:
mozregression --launch 2018-12-23 --pref gfx.webrender.all:true -a https://bug1509248.bmoattachments.org/attachment.cgi?id=9026983

Not reproducible with:
mozregression --repo try --launch cd65b25e4fb3e1c76888dd3c0a907654d97842cf --pref gfx.webrender.all:true -a https://bug1509248.bmoattachments.org/attachment.cgi?id=9026983
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1503373
You need to log in before you can comment on or make changes to this bug.