Mozilla ignores stylesheet

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Czech
--
major
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Michal Taborsky, Assigned: Nikolai Prokoschenko)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Mozilla simply doesn't use the stylesheet defined in page header. All other
browsers use it correctly.

Reproducible: Always
Steps to Reproduce:
1. Open the page and see.


Actual Results:  The page is without style.

Expected Results:  It should use the stylesheet.

Previous version, not sure about the exact version number, but it was before 1.0
release candidates, worked fine.
The stylesheet is being served as text/plain, and the page triggers standards
mode (see http://mozilla.org/docs/web-developer/quirks/ ).  Since we don't
support the text/plain stylesheet language, and the type returned by the HTTP
server overrides the advisory type in the link on the page, we ignore the
stylesheet.
Assignee: dbaron → prokosch
Component: Style System → Europe: East
Product: Browser → Tech Evangelism
QA Contact: ian → momoi
Version: other → unspecified
Page is displaying correctly, server sends text/css as the Mime type. Bug should
be marked as resolved/fixed.
..as of reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
tech evang june 2003 reorg
Component: Europe: East → Czech
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.