Closed Bug 1509272 Opened 9 months ago Closed 7 months ago

Bug in effect Zoom In / Out

Categories

(Core :: Web Painting, defect, P2)

63 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: ralineri, Assigned: miko)

References

Details

(Whiteboard: [qa-66b-p2])

Attachments

(3 files, 2 obsolete files)

Attached video Firefox Bug.mp4
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Steps to reproduce:

I accessed the home page of the site http://ead.cneceduca.com.br


Actual results:

A zoom in / out animation failure occurs, which was not the case in the previous version.


Expected results:

The effect should not show the "white bands", as can be seen in other browsers.
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=985e470b78d88f0edd223118cfcbb9b8b5670b1a&tochange=4ef564f7ffe2c6c138513d314e87d0332002cd6a
Blocks: 1475971
Status: UNCONFIRMED → NEW
Component: CSS Transitions and Animations → Web Painting
Ever confirmed: true
Flags: needinfo?(matt.woodrow)

Cannot reproduce this on macOS. Did the page change, or is the bug fixed?

Flags: needinfo?(matt.woodrow) → needinfo?(emilio)
Priority: -- → P3
Attached file Testcase that reproduces the issue. (obsolete) —

The page changed and they worked-around the bug by de-accelerating the animation on Firefox (see the zoomFirefox stuff).

I ended up with this test-case that shows the issue on non-webrender.

Flags: needinfo?(emilio)
Attachment #9037981 - Attachment mime type: text/plain → text/html
Assignee: nobody → mikokm
Status: NEW → ASSIGNED
Priority: P3 → P2
Attached file testcase.html (obsolete) —

Further reduced testcase. Flipping layout.display-list.retain;false fixes the problem.

Attachment #9037981 - Attachment is obsolete: true
Attached file testcase.html
Attachment #9038224 - Attachment is obsolete: true

It appears that on this page, the size of the animated element is fluctuating between being above vs. below the pre-render threshold.

That is, when the animation is close to the 1.0 scale, the element is below the threshold (since the thresold is a little bit larger than the browser window size). When the animation is close to the 1.5 scale, the element is above the threshold.

The bug seems to occur when we are above the threshold and choose not to pre-render, suggesting that the issue is in the main-thread codepath, not the compositor codepath.

Pushed by mikokm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9e7fe63b341a
Always use new transform display items r=mattwoodrow
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Whiteboard: [qa-66b-p2]
You need to log in before you can comment on or make changes to this bug.