Closed Bug 15093 Opened 21 years ago Closed 20 years ago

[DOGFOOD][CRASH] when the Wall Street Journal is loaded as start page & viewing any msg, a crash occurs

Categories

(MailNews Core :: Backend, defect, P3)

All
Other
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: pmock, Assigned: sspitzer)

References

()

Details

(Whiteboard: [PDT-])

Build Date & Platform Bug Found:
  Win32 seamonkey build 1999-09-27-09 installed on P166 win98
  Linux seamonkey build 1999-09-27-09 installed on P200 RedHat 6.0

Overview Description:
 Chris Saito (chriss@netscape.com)found a crash when he changed his start
page to the Wall Street Jounal and tries to read any mail message.  It
consistently crashes selecting any message.

Chris described the problem as:
 "On two machines I crash when trying to read any message. Basically a GPF
occurs when I select a message - i.e. it never displays.

  Machine 1 is running NT4 with yesterday's build
  Machine 2 is running Win95 with today's build (BTW this is a brand new machine
  that I received today)."

I was able to duplicate his problem on his machine and mime.  It turns out that
he set his Messenger start page to Wall Street Journal web page.  Chris has a
subscription to this site. His password is saved in his cookie.txt file  Once
this page is loaded, any message that we try to display crashes the application.

If we do not save the Wall Street Journal login password and don't login, I can
display mail messages.  If rename his migrated cookie file and start with a
generic cookie file, this problem does not occur.

I was able to reproduce this problem on Win32 and Linux.

Steps to Reproduce: (Win & Linux)
(Seth, I will bring by Chris's cookie file.  He requested that we do not post
his password or cookie file with the bug report).

0) Use an existing 5.0 preference file
1) Edit the prefs.js file and add the following user pref:
   user_pref("mailnews.start_page.url",
"http://interactive.wsj.com/edition/current/summaries/front.htm");
2) Copy chris's cookie file to your profile directory
3) Run Apprunner -mail
   Messenger should launch and the Wall Street Journal web page is displayed in
the message pane.  It should automatically logged you in through his cookie
file.
4) Expand your mail folder list (Chris and I are using IMAP)
5) Select any mail message
   Crash.


Actual Results:
  The Wall Street Journal web page gets located as the start page.  Once I
select to display (any) mail message, apprunner crashes.

Expected Results:
  Apprunner should display my requested mail message and not crash.

Additional Builds and Platforms Tested On:
 This problem started last week when Chris tried to migrate his 4.x profile.  He
firsted reported the problem in the win32 1999-09-23-08 build.

I have not been able to test on MacOS.  Apparently migration feature on Mac does
not migrate the 4.x MagicCookie file.  I am trying to get Chris's username and
password.

I was not able to try any other web site because I don't have a
subscription/account on any web site that requires a login and password.

Additional Information:
 Work around: edit the prefs.js line and remove or modify the line
user_pref("mailnews.start_page.url",
"http://interactive.wsj.com/edition/current/summaries/front.htm");  to point to
a different location.
hmm, I wonder what would happen if you load the WSJ in the browser window.
Then, go to mail and select a message.  Is this particular to the WSJ being in
the start page, I wonder?
I tried Lisa's suggestion to load the WSJ page in the browser and did not have
it load the page in the Messenger pane. When I selected a mail message to load,
it did not crash in this scenario.  It looks like this problem is in Messenger
only.

I looked at my talkback incident report 13942355
/mailnews/imap/src/Makefile.in, line 56 -- nsImapProtocol.cpp \

On chris's nt machine, it put up the following error dialog

"NSPR:EventReceiver:apprunner.exe - Application Error The
instruction at '0x6029411a' referenced memory at
'0x00000000'. The memory could not be read."

His talkback incident id is 13912747
The lxr.mozilla.org search gave the same info...

/mailnews/imap/src/Makefile.in, line 56 -- nsImapProtocol.cpp \
accepting.  marking all milestone 11.
QA Contact: lchiang → pmock
changing QA assigned to pmock
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
worksforme
Status: RESOLVED → REOPENED
Note: In order to see the problem, you must be automatically logged into the
Wall Street Journel site.

Re-openning bug.  I believe Seth may have Chris Saito password now.
Resolution: WORKSFORME → ---
Target Milestone: M11 → M15
m15
Status: REOPENED → ASSIGNED
Summary: Crash when the Wall Street Journal is loaded as start page & viewing any msg → [CRASH] when the Wall Street Journal is loaded as start page & viewing any msg, a crash occurs
accepting, looking into this now.
I've got a stack trace from linux.  I see it there, too.

adding wtc to the cc list, to see if this rings a bell.

#0  0x402a3111 in __kill ()
#1  0x401ef425 in pthread_cond_signal (cond=0x899db64) at restart.h:21
#2  0x401cb17c in pt_PostNotifies (lock=0x89b272c, unlock=1) at ptsynch.c:106
#3  0x401cb67d in PR_Unlock (lock=0x89b272c) at ptsynch.c:195
#4  0x401cc3db in PR_ExitMonitor (mon=0x89b2728) at ptsynch.c:520
#5  0x4137d107 in nsImapProtocol::OnDataAvailable (this=0x89b2b48, ctxt=0x0,
aIStream=0x89b4050, aSourceOffset=25969, aLength=1387) at
nsImapProtocol.cpp:1123
#6  0x40904251 in nsOnDataAvailableEvent::HandleEvent (this=0x414036d8) at
nsAsyncStreamListener.cpp:412
#7  0x409037ea in nsStreamListenerEvent::HandlePLEvent (aEvent=0x41407538) at
nsAsyncStreamListener.cpp:169
#8  0x4019a36b in PL_HandleEvent (self=0x41407538) at plevent.c:537
#9  0x4019a27c in PL_ProcessPendingEvents (self=0x89b3ad0) at plevent.c:498
#10 0x401589e9 in nsEventQueueImpl::ProcessPendingEvents (this=0x89b3aa8) at
nsEventQueue.cpp:190
#11 0x4051c1ec in event_processor_callback (data=0x89b3aa8, source=18,
condition=GDK_INPUT_READ) at nsAppShell.cpp:228
#12 0x4051baff in our_gdk_io_invoke (source=0x89b3b98, condition=G_IO_IN,
data=0x899a700) at nsAppShell.cpp:49
#13 0x406b93ca in g_io_unix_dispatch ()
#14 0x406baa86 in g_main_dispatch ()
#15 0x406bb041 in g_main_iterate ()
#16 0x406bb1e1 in g_main_run ()
#17 0x405e77a9 in gtk_main ()
#18 0x4051c6ff in nsAppShell::Run (this=0x80a06b0) at nsAppShell.cpp:395
#19 0x403a1351 in nsAppShellService::Run (this=0x809f940) at
nsAppShellService.cpp:480
#20 0x804b7e8 in main1 (argc=2, argv=0xbffff7f4) at nsAppRunner.cpp:575
#21 0x804ba59 in main (argc=2, argv=0xbffff7f4) at nsAppRunner.cpp:665
#22 0x4029ccb3 in __libc_start_main (main=0x804b8cc <main>, argc=2,
argv=0xbffff7f4, init=0x8049e08 <_init>, fini=0x804e7b8 <_fini>,
rtld_fini=0x4000a350 <_dl_fini>, stack_end=0xbffff7ec) at
../sysdeps/generic/libc-start.c:78
hmm that stack may be bogus.  I've got a better looking one from my windows
build, that doesn't involve nspr.

removing wtc, I don't think this has to do with nspr.
after debugging, I have a theory.

loading "http://interactive.wsj.com/edition/current/summaries/front.htm" in
apprunner (and in the message pane as the start window) causes a javascript
exception.

JavaScript Error: ReferenceError: insideWindowWidth is not defined
URL: http://interactive.wsj.com/edition/current/summaries/front.htm
LineNo: 158

this exception causes problems.

later, in nsImapProtocol.cpp, line 2018, we call
msgurl->GetMessageFile(getter_AddRefs(fileSpec));

when this crash happens, fileSpec is null, and a few lines later we
derefernce fileSpec, and boom.

the JS exception may not have anything to do with it, but I have a hunch it
does.

this bug is bad...any start page with bad JS can cause a crash later.

still investigating.
Blocks: 18471
Summary: [CRASH] when the Wall Street Journal is loaded as start page & viewing any msg, a crash occurs → [DOGFOOD][CRASH] when the Wall Street Journal is loaded as start page & viewing any msg, a crash occurs
Target Milestone: M15 → M12
marking m12 / dogfood.

I think something bigger (and worse) is going on here.
Whiteboard: [PDT-]
Putting on PDT- radar for now. Support for change of start page not required for
dogfood.  However, if you open this page in Browser, can you view mail?
The last time I checked, this problem does not occur if I view the Wall Street
Journal in the browser and try to view a mail message.
Update:
 Chris Saito and I are seeing a different behavior on Win32 commercial seamonkey
build.  If we have the messenger start page set to the Wall Street Journal, we
can not view any mail message.  When we select a mail message, the message pane
is cleared and the status bar shows something happening.  The status bar goes
thought "Openning folder...Downloading message...Document:Done".  Nothing
displays in the message pane.  We select other messages (simple messages) but
nothing gets rendered.

If I comment out the start page user preference,
user_pref("mailnews.start_page.url",
"http://interactive.wsj.com/edition/current/summaries/front.htm");
and restart apprunner, the problem goes away.

Apprunner crashes on when I quit the apprunner.
I forgot to mention that I was using today win32 commercial seamonkey build
1999-11-18-09-m12.
Target Milestone: M12 → M13
lisa told me that she is able to get the linux version into a state where she
can't load messages.

akkana also has a bug like this one.

perhaps all these problems are related?

akkana / lisa, can you add the bug # for those bugs to this bug report so I can
take a look?
akkana's bug is http://bugzilla.mozilla.org/show_bug.cgi?id=20546
I don't have a bug for what I'm seeing yet because I don't have the reproducible
steps. Still trying though.
Target Milestone: M13 → M14
moving to m14.
An update - I have my start page set to the WSJ and everything seems to be
working normally. I'm running last Sunday's build.

So maybe this bug should marked Works for me?
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
excellent.

I get mscott fixed it when he re-wrote message display.

marking worksforme.
Verified as worksforme using:
 win32 commercial seamonkey build 00050412-m16 installed on Dell P500, Win98
 macos commercial seamonkey build 00050412-m16 installed on G3/400, MacOS 9.04
 linux commercial seamonkey build 00050412-m16 installed on P200, RedHat 6.1


I had to load a separate bug 38242 b/c message fail to load in the message pane 
if wsj page is loaded.
http://bugzilla.mozilla.org/show_bug.cgi?id=38242
Status: RESOLVED → VERIFIED
No longer blocks: 18471
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.