Closed Bug 1509352 Opened Last year Closed Last year

Crash in AsyncShutdownTimeout | profile-change-teardown | Extension shutdown: fxmonitor@mozilla.org

Categories

(Toolkit :: Add-ons Manager, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1464938
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- fix-optional

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

Attached image crash spikes.png
This bug was filed from the Socorro interface and is
report bp-b6426585-4c3c-44f3-b66c-888bf0181122.
=============================================================

AsyncShutdownTimeout 	

{"phase":"profile-change-teardown","conditions":[{"name":"Extension shutdown: fxmonitor@mozilla.org","state":{"state":"Startup: Run manifest"},"filename":"resource://gre/modules/addons/XPIProvider.jsm","lineNumber":2211,"stack":["resource://gre/modules/addons/XPIProvider.jsm:startup/<:2211","resource://gre/modules/AsyncShutdown.jsm:observe:541"]}]}

=============================================================

these crash reports are spiking up in volume after the rollout of monitor in november. they are primarily hitting users on 63.0.1, where the signature is accounting for a whopping 33% of all browser crashes during the past couple of days.

numerous user comments in crash reports are indicating that the crash is taking place during firefox update from 63.0.1 to 63.0.3:
https://crash-stats.mozilla.com/signature/?product=Firefox&signature=AsyncShutdownTimeout%20%7C%20profile-change-teardown%20%7C%20Extension%20shutdown%3A%20fxmonitor%40mozilla.org&date=%3E%3D2018-11-15#comments
from the comments it's unclear if the update is ultimately succeeding or if the affected users might get stuck on the old firefox release after the crash.

a similar pattern already took place during the first rollout of monitor in september - after each new firefox dot-release the async shutdown timeout reports were spiking up for the prior version (see attached screenshot).
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1464938
You need to log in before you can comment on or make changes to this bug.