Floating first-letter hides all further content

RESOLVED DUPLICATE of bug 158037

Status

()

Core
Layout
P2
major
RESOLVED DUPLICATE of bug 158037
16 years ago
16 years ago

People

(Reporter: Phil Housley, Assigned: Marc Attinasi)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build 2002061008 Win98 SE:

Floating first-letter of an element hides all further content - This can be seen
in the "Basic Styles" viewer demo in Moz, and I'll attach a cut down version. 
If element:first-letter {float:*} is applied to an element, no further content
seems to be visible.  This occurs every time for me.
(Reporter)

Comment 1

16 years ago
Created attachment 87244 [details]
Test case

Comment 2

16 years ago
I see the problem in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a)
Gecko/20020610.

Not displaying text is a major problem.

This might be CSS, not Layout.

pi
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All

Updated

16 years ago
Priority: -- → P2

Updated

16 years ago
Target Milestone: --- → Future

Comment 3

16 years ago
Why is this marked Future by kmcclusk@netscape.com? Missing text on a web page
is evil. And QA set priority to P2 anyways.

pi
(Reporter)

Comment 4

16 years ago
This seems to have been fixed somewhere.  It works in 2002062508 for me.  Could
someone check on a non win9x platform.
Related to bug 158037?

Comment 6

16 years ago
WFM MOX 2002-08-18-03
The bug is still there with build 2002091110 WinXP, I was about to file a bug
about it !

Here is the code I tried that showed the bug :

p { text-align: justify; }

p.centre { text-align: center; }

p.centre:first-letter {  
	float: none !important;
 }

 p:first-letter  {  
  color: #ad8014;
  font-weight: bold;
  font-size: 200%;
  float: left ;
 }


The paragraph with the class "centre' totally disappears apart from the first
letter.

Pascal

Comment 8

16 years ago
Pascal, please attach a testcase in valid HTML. Anyways, as David suggested, bug
158037 is related. I even think it is a dupe, so please use that bug.

pi

*** This bug has been marked as a duplicate of 158037 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

16 years ago
Sorry, could I just ask the logic of marking this bug as a dupe of one posted
after it?

Comment 10

16 years ago
The other bug seems to have more information.

pi
You need to log in before you can comment on or make changes to this bug.