Closed Bug 15096 Opened 21 years ago Closed 19 years ago

UI: 3-Pane, Visual, General Menu Problems

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.3

People

(Reporter: nbaca, Assigned: timeless)

References

()

Details

(Keywords: helpwanted, Whiteboard: ui)

Attachments

(1 file)

Build 1999092709M11: Win32/NT4
Note: I haven't checked menu items in the Linux or Mac environments yet. This is
a first attempt to report general menu bugs. I've concentrated on menu items,
that are enabled, to see if the Control-Command Keys and Access Keys work. I've
also noted problems with typos, position of an item and removal of an item.

3-Pane/Visual

1. File
A. Control-Command Keys
    1. Print needs "Ctrl+P"
B. Access Keys
    1. New Message needs the "M" underlined
    2. "New" needs "N" underlined
    3. "Close", remove underline from "C"
    4. "Save as" needs first "S" underlined
    5. "Get New Messages" needs "G" underlined
    6. "Send Unsent Messages" needs "d" underlined
    7. "Subscribe" needs "b" underlined
    8. "Empty Trash" needs "y" underlined
    9. "Compact This Folder" the "t" in "Compact" underlined
    10. "Print" needs "P" underlined

C. Change text to state
    1. Get New Messages should state "Get Messages"
    2. Empty Trash should state "Empty Trash on <server>"
    3. Compact This Folder should state "Compact Folders"

D. Remove menu item
    1. "Load First Draft Message"
    2. "Rename Folder"

E. Position of menu item
    1. "Subscribe" should be between "Send Unsent Messages" and "Empty Trash".

2. Edit
A. Control-Command Keys
    1. Delete needs "Del"
    2. Preferences needs "Ctrl+E"
B. Access Keys
    1. "Delete" needs "D" underlined
    2. "Select" needs "e" underlined
    3. "Message Filters" needs "i" underlined
    4. "Account Setup" needs "A" underlined
    5. "Preferences..." needs the first "e" underlined
C. Change text to state
    1. "Delete Message" and Delete Folder" should merge into one option called
"Delete <Message/Folder/Accounts>". This menu item will change depending on what
object is selected.

3. View
A. Control-Command Keys, OK.
B. Access Keys
    1. "Sort" needs "o" underlined
    2. "Messages-->" needs "M" underlined
C. Change text to state
    1. Sort should state "Sort by-->"
    2. Messages should state "Messages-->

4. Search
Not much to test right now so OK.

5. Go
A. Control-Command Keys
   1. Next/Message needs "Shift+N"
    2. Next/Unread Message needs "N"
    3. Previous/Message needs "Shift+P"
    4. Previous/Unread Message needs "P"
B. Access Keys
    a. "Next" needs "N" underlined
    b. "Next/Message" needs "M" underlined
    c. "Next/Unread Message" needs "U" underlined
    d. "Next/Flagged Message" "F" underlined
    e. "Previous" needs "P" underlined
    f. "Previous/Message" needs "M" underlined
    g. "Previous/Unread Message" needs "U" underlined
    h. "Previous/Flagged Message" needs "F" underlined

D. Remove menu items
    1. "5000 message folder test"

6. Message
A. Control-Command Keys
    1. New Message needs "Ctrl+M"
    2. Reply needs "Ctrl+R"
    3. Reply to All needs "Ctrl+Shift+R"
    4. Forward needs "Ctrl+L"
B. Access Keys
    1. "New Message" needs "N" underlined
    2. "Reply" needs "R" underlined
    3. "Reply to All" needs "p" underlined
    4. "Forward" needs "w" underlined
    5. "Forward as" needs "o" underlined
    6. "Move Message" needs the "M" in "Move" underlined
    7. "Copy Message" needs "C" underlined
    8. "Mark" needs "k" underlined
    9. "Forward as/Inline" needs the first "I" underlined
    10. "Forward as/Attachment" the "A" in "Attachment" underlined
    11. "Mark/as Read" needs "R" in "Read" underlined
    12. "Mark/All Read" needs the "A" in "All" underlined
    13. "Mark/Flag" needs "F" underlined
QA Contact: lchiang → nbaca
QA Contact to nbaca.
Status: NEW → ASSIGNED
Target Milestone: M11
1B2 New should have 'e' underlined, spec is wrong.
1B3 Close should have 'C' underlined, spec is wrong.
2A2 It is there.
2B5 It is there.
Target Milestone: M11 → M12
Moving to M12
Depends on: 15126
Adding "depends on 15126" because we need the accesskey to function in submenus
to completely fix this bug.
Mass move to M13.
Target Milestone: M13 → M14
Marking M14 in case we end up redesigning the menus. cc jglick
Moving to M15.
Target Milestone: M14 → M15
Whiteboard: ui
Mass moving to M17
Target Milestone: M15 → M17
Summary: 3-Pane: Visual, General Menu Problems → UI: 3-Pane, Visual, General Menu Problems
Not beta2 stopper. Marking M18.  Add beta2 keyword if you disagree.
Target Milestone: M17 → M18
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW
*** Bug 35354 has been marked as a duplicate of this bug. ***
*** Bug 35354 has been marked as a duplicate of this bug. ***
timeless - do you want to look at this also?
sure; feel free to just assign these bugs to me. Updating blockers, most of 
these are already fixed, but it'll help the reporter keep tabs.
Assignee: putterman → timeless
Mass accepting.
Status: NEW → ASSIGNED
Target Milestone: M18 → mozilla0.9
Target Milestone: mozilla0.9 → mozilla0.9.2
Attached patch patchSplinter Review
Target Milestone: mozilla0.9.2 → mozilla0.9.3
r-kerz
seth or someone on the mail team needs to sr= this one.
sr=hewitt
fix checked in, tabs removed per hewitt and the search menu movement which 
shouldn't have been in the patch wasn't committed.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
can you attach the actual patch that did get checked in?

-                <menuitem label="&fileHereMenu.label;" disabled="true"/>
+                <menuitem label="&fileHereMenu.label;" 
accesskey="&fileHereMenu.accesskey;" disabled="true"/>

why add the access key for something that is permanetly 
disabled?                 

timeless, next time, please wait for someone on the mailnews team to review.

hewitt and kerz are quality reviewers, but all mailnews changes need to go 
through the mailnews team.
where are my manners?  I should have prefaced that comment with:

"thanks for fixing this mailnews bug.  but next time..."

Create attachment Bug 15096 
No file was provided, or it was empty.

CVS can create the diff for you. these are the relevant fragments of commands.
-u -r1.108 -r1.109 messenger.dtd
-u -r1.131 -r1.132 mailWindowOverlay.xul

just because something's permanently disabled doesn't mean it will always be 
that way (or that it's really permanently disabled -- javascript or something 
could change it). 
-                <menuitem label="&fileHereMenu.label;" disabled="true"/>
+                <menuitem label="&fileHereMenu.label;"
accesskey="&fileHereMenu.accesskey;" disabled="true"/>

that was for a no select folder in the file message picker.

you can't have messages in a no select folder.  so in this case, that menuitem
should *always* be disabled.

Specifying the access key doesn't allow the user to somehow select that
menuitem, does it?  I'll try in this morning's build.
Trunk build 2001-08-01-02: WinMe
Trunk build 2001-08-01-08: Mac 9.04
Trunk build 2001-08-01-06: Linux RH 6.2
Can I verify this since it appears that all of the items originally listed have
been fixed. The spec changed since this bug was orignally written. The following
items were changed in the spec and now look ok.

1. File
B3. Close should keep underline "C", ok.
C1. Get New Messages should still state Get New Messages, ok.
C2. Empty Trash should state "Empty Trash on <server>", I will check for a
separate bug on this.

2. Edit
A2. Preferences, the spec no longer requires Ctrl+E, ok.
B2. Select should underline "l", ok.
B4. Account Setup is now names Mail/News Account Settings and "M" is underlined, ok.
C1. Delete Message and Delete Folder are working as expected. It never states
Delete Account. 
Jen, is this still a requirement or should the spec be updated?

3. View
B1. Sort should have "b" underlined, ok.
B2. Messages should have "a" underlined, ok.

6. Message
B4. Forward should have "F" underlined, ok.
Bug# 67837 tracks the progress for item 1C2 "Empty Trash on <server>".
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.