Closed Bug 1509774 Opened 11 months ago Closed 11 months ago

jstests fails if it's executed without virtualenv

Categories

(Core :: JavaScript Engine, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: arai, Assigned: Ms2ger)

References

Details

Attachments

(1 file)

similar to bug 1495601, but this time the error happens in different place, so new bug.

$ python jstests.py --jitflags=all /tmp/mozilla-unified/obj-spidermonkey/dist/bin/js
Traceback (most recent call last):
  File "jstests.py", line 556, in <module>
    sys.exit(main())
  File "jstests.py", line 517, in main
    test_count, test_gen = load_tests(options, requested_paths, excluded_paths)
  File "jstests.py", line 438, in load_tests
    excluded_paths)
  File "jstests.py", line 339, in load_wpt_tests
    import manifestupdate
  File "/tmp/mozilla-unified/testing/web-platform/manifestupdate.py", line 17, in <module>
    import manifestdownload
  File "/tmp/mozilla-unified/testing/web-platform/manifestdownload.py", line 7, in <module>
    import requests
ImportError: No module named requests

this works if I activate virtualenv created for full firefox build.

If virtualenv is required now, it should detect it and warn about it.
Attached patch Patch v1Splinter Review
No, using the virtualenv is (or should be) optional. Unfortunately, python packaging is a mess, and the existing code works for me, because I've got the requests package installed system-wide. This patch ensures that we use the in-tree version of the package, and should work without depending on the system package.
Assignee: nobody → Ms2ger
Status: NEW → ASSIGNED
Attachment #9027469 - Flags: review?(jdemooij)
Comment on attachment 9027469 [details] [diff] [review]
Patch v1

Review of attachment 9027469 [details] [diff] [review]:
-----------------------------------------------------------------

I hit this too and managed to run tests locally with |pip install requests|. I can confirm this fixes it after a |pip ininstall requests|
Attachment #9027469 - Flags: review?(jdemooij) → review+
Pushed by Ms2ger@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/485c48227d15
Add the requests library to the path in jstests; r=jandem
https://hg.mozilla.org/mozilla-central/rev/485c48227d15
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.