Closed Bug 1509818 Opened Last year Closed Last year

Crash in java.lang.OutOfMemoryError: at java.lang.StringBuilder.toString(StringBuilder.java)

Categories

(Firefox for Android :: Session Restore, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1492706

People

(Reporter: gsvelto, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-84990601-e6a1-4047-a179-9ba440181126.
=============================================================

Java stack trace:

java.lang.OutOfMemoryError
	at java.lang.StringBuilder.toString(StringBuilder.java:408)
	at org.json.JSONStringer.toString(JSONStringer.java:430)
	at org.json.JSONObject.toString(JSONObject.java:690)
	at org.mozilla.gecko.GeckoApp.restoreSessionTabs(GeckoApp.java:1636)
	at org.mozilla.gecko.GeckoApp.access$200(GeckoApp.java:112)
	at org.mozilla.gecko.GeckoApp$9.run(GeckoApp.java:1152)
	at android.os.Handler.handleCallback(Handler.java:751)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:154)
	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:43)

Looking at the unredacted Java stack traces it seems that we're trying to allocate a string tens of megabytes in size (I've found samples between 25 and 80MiB). I also noticed that some users _never_ close their tabs on Fennec so it might be that this is coming from users with very large numbers of open tabs.
... eventually combined with some pathological tabs that end up creating disproportionately large session history entries.
Telemetry does indeed show that there are a few users where the raw file size (on disk) is north of 10 MB.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1492706
See Also: → 1512035
You need to log in before you can comment on or make changes to this bug.