Closed Bug 1509875 Opened 11 months ago Closed 10 months ago

The AAC audio player is not working for 7.1 channel

Categories

(Core :: Audio/Video: Playback, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla65
Tracking Status
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- verified

People

(Reporter: rares.doghi, Assigned: jya)

Details

Attachments

(3 files, 2 obsolete files)

[Affected versions]: 
Nightly 65.0a1

[Affected platforms]:
Platforms: All


[Steps to reproduce]:
1. Open the Firefox browser and reach https://www2.iis.fraunhofer.de/AAC/multichannel.html
2. Reach the 7.1 Channel Identification.
3. Click the AAC Bitstream player


Expected Result:
The Audio File should play without issues.

Actual Results:
The Audio player will not start, only the Original Wave File is working for the 7.1 Channel.
Please note that the Audio player works correctly on Chrome, also none of the other players have issues.
Issue appears to be in the MP4 demuxer, it reads this as a 14 channels mp4
Rank: 15
Priority: -- → P2
Assignee: nobody → jyavenard
Attachment #9029518 - Attachment is obsolete: true
Attachment #9029517 - Attachment is obsolete: true
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc0e006e1ee9
Update cubeb from upstream to e5c3a1d8a68c. r=padenot
https://hg.mozilla.org/integration/autoland/rev/b6fbf0a6d8f7
Cherry-pick mp4parse-rust commit 4472ec104e2b38e6379. r=padenot
https://hg.mozilla.org/integration/autoland/rev/b322cc0a757f
P1. Retrieve extended profile from mp4parse. r=kinetik
Flags: qe-verify+

Hello,

I can still reproduce this issue under the following OS's: Windows 10 x64 and Ubuntu 18.04. I used FX 65.0b9 Build ID: 20190107180200.

Additional Note:
As far as I can see this fix only worked for macOS X 10.13.

Flags: needinfo?(jyavenard)

(In reply to Daniel Cicas [:dcicas], Release QA from comment #10)

Hello,

I can still reproduce this issue under the following OS's: Windows 10 x64 and Ubuntu 18.04. I used FX 65.0b9 Build ID: 20190107180200.

Additional Note:
As far as I can see this fix only worked for macOS X 10.13.

What does the console show for those when you attempt to play it?

Flags: needinfo?(jyavenard)

The issue is in the Windows decoder, which doesn't support more than 6 channels audio. Edge can't play it either.

Nothing we can do about it.

For Linux, you must have ffmpeg installed. WFM on ubuntu 18.10

Hello,

I tested now on Ubuntu 18.04 TLS and the issues seems fix and as per my previous comment the fix worked on macOS X 10.13. And based on the above comment (comment #12) on Windows this is expected to fail. So I think we can mark this issue as verified fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.