Closed Bug 1509977 Opened Last year Closed Last year

Update the prefs language change UI to the latest FX version

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 65.0

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(1 file, 1 obsolete file)

FX made some changes we can now follow.

Bug 1469696: Support installing official language packs from AMO
Bug 1505594: Removing a requested locale puts it ahead of its label in the available dropdown
Bug 1493711: Pref off downloading langpacks outside of release
Bug 1505594: Put removed browser locale in the right order
Bug 1509080: Clear language change confirmation content on hide
Bug 1488442: Support disabled language packs in multilingual UI

This doesn't include bug 1479008 because we don't have this available on ATN (see also bug 1487315).
Attached patch 1509977-language-prefs.patch (obsolete) — Splinter Review
This works like the FX version. But what I see on TB is the Warning: ReferenceError: reference to undefined property "value"[Learn More] messengerLanguages.js:268:10 When I open the language selection dialog. Pleas can you check why this happens?

I also implemented bug 1469696 but set the pref intl.multilingual.downloadEnabled to false because ATN doesn't support it.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9027650 - Flags: review?(jorgk)
Comment on attachment 9027650 [details] [diff] [review]
1509977-language-prefs.patch

Review of attachment 9027650 [details] [diff] [review]:
-----------------------------------------------------------------

bz qimport spits the dummy here.

::: mail/locales/en-US/messenger/preferences/languages.ftl
@@ +41,5 @@
> +
> +messenger-languages-installed-label = Installed languages
> +messenger-languages-available-label = Available languages
> +
> +messenger-languages-error = { -brand-short-name } can’t update your languages right now. Check that you are connected to the internet or try again.

There is an encoding error in the file. See the ... and the "smart" ' - can’t
Attachment #9027650 - Attachment is obsolete: true
Attachment #9027650 - Flags: review?(jorgk)
Attachment #9028901 - Flags: review?(jorgk)
Comment on attachment 9028901 [details] [diff] [review]
1509977-language-prefs.patch

Thanks, that was a lot of work. Sorry about the delay, other fires burning hotter.

This works for me. I don't see the error at messengerLanguages.js:268:10. Any specific steps or language packs needed to reproduce it?

I've compared messengerLanguages.js to browserLanguages.js and there are a few differences, maybe there is another port necessary.
Attachment #9028901 - Flags: review?(jorgk) → review+
(In reply to Jorg K (GMT+1) from comment #4)
> Comment on attachment 9028901 [details] [diff] [review]
> 1509977-language-prefs.patch
> 
> I've compared messengerLanguages.js to browserLanguages.js and there are a
> few differences, maybe there is another port necessary.

This would be mostly bug 1479008, see comment 0.
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/23e639499671
Port bugs 1469696, 1505594, 1493711, 1505594, 1509080 and 1488442. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 65.0
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/3bb8dc6872e1
Follow-up: Fix copy/paste errors found by lint in disabled code. rs=bustage-fix DONTBUILD
You need to log in before you can comment on or make changes to this bug.