Closed Bug 1510099 Opened 11 months ago Closed 11 months ago

Intermittent NoSuchWindowException: Browsing context has been discarded after Assertion failure: aVsyncTimestamp <= *&rightnow, at z:/build/build/src/layout/base/nsRefreshDriver.cpp:669

Categories

(Core :: Graphics, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1306896

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: dluca [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=213896696&repo=autoland

https://queue.taskcluster.net/v1/task/Tbhs_aZ3TYCM1Fm-Auc-Fg/runs/0/artifacts/public/logs/live_backing.log

INFO - TEST-OK | /webusb/usbEndpoint.https.any.html | took 261ms
19:15:04     INFO - TEST-START | /webusb/usbInTransferResult.https.any.html
19:15:04     INFO - Closing window 6442451068
19:15:04     INFO - PID 4488 | ++DOCSHELL 0C7CD800 == 19 [pid = 4252] [id = {0f380049-1c5b-4db5-8d89-032e9cce3628}]
19:15:04     INFO - PID 4488 | ++DOMWINDOW == 57 (09831580) [pid = 4252] [serial = 127] [outer = 00000000]
19:15:04     INFO - PID 4488 | ++DOMWINDOW == 58 (0FEE0000) [pid = 4252] [serial = 128] [outer = 09831580]
19:15:04     INFO - PID 4488 | ++DOMWINDOW == 59 (0FEE5C00) [pid = 4252] [serial = 129] [outer = 09831580]
19:15:04     INFO - PID 4488 | [Child 4252, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/xpcom/io/NonBlockingAsyncInputStream.cpp, line 182
19:15:04     INFO - ....
19:15:04     INFO - TEST-OK | /webusb/usbInTransferResult.https.any.html | took 262ms
19:15:04     INFO - TEST-START | /webusb/usbInTransferResult.https.any.worker.html
19:15:04     INFO - Closing window 6442451071
19:15:04     INFO - PID 4488 | ++DOCSHELL 0FEE3000 == 20 [pid = 4252] [id = {68fa8112-812a-4934-bc8a-e5cdbaebcc10}]
19:15:04     INFO - PID 4488 | ++DOMWINDOW == 60 (098316C0) [pid = 4252] [serial = 130] [outer = 00000000]
19:15:04     INFO - PID 4488 | ++DOMWINDOW == 61 (0FEE7000) [pid = 4252] [serial = 131] [outer = 098316C0]
19:15:04     INFO - PID 4488 | ++DOMWINDOW == 62 (0FEE9C00) [pid = 4252] [serial = 132] [outer = 098316C0]
19:15:04     INFO - PID 4488 | [Child 4252, Main Thread] WARNING: 'NS_FAILED(rv)', file z:/build/build/src/xpcom/io/NonBlockingAsyncInputStream.cpp, line 182
19:15:04     INFO - ....
19:15:04     INFO - TEST-OK | /webusb/usbInTransferResult.https.any.worker.html | took 302ms
19:15:04     INFO - TEST-START | /webusb/usbInterface.https.any.worker.html
19:15:04     INFO - Closing window 6442451074
19:15:04     INFO - PID 4488 | Assertion failure: aVsyncTimestamp <= *&rightnow, at z:/build/build/src/layout/base/nsRefreshDriver.cpp:669
19:15:04     INFO - PID 4488 | #01: mozilla_dump_image[Z:\task_1543257557\build\application\firefox\xul.dll +0x3658b55]
19:15:04     INFO - PID 4488 | #02: DumpBidiLine[Z:\task_1543257557\build\application\firefox\xul.dll +0x397940e]
19:15:04     INFO - PID 4488 | #03: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0xaff256]
19:15:04     INFO - PID 4488 | #04: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0x9e5edf]
19:15:04     INFO - PID 4488 | #05: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0x7568d6]
19:15:04     INFO - PID 4488 | #06: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0x754f43]
19:15:04     INFO - PID 4488 | #07: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0x755a6d]
19:15:04     INFO - PID 4488 | #08: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0x755eb1]
19:15:04     INFO - PID 4488 | #09: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x10f27f]
19:15:04     INFO - PID 4488 | #10: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x112684]
19:15:04     INFO - PID 4488 | #11: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0x7597a7]
19:15:04     INFO - PID 4488 | #12: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x717561]
19:15:04     INFO - PID 4488 | #13: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x71747c]
19:15:04     INFO - PID 4488 | #14: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x71734f]
19:15:04     INFO - PID 4488 | #15: mozilla_dump_image[Z:\task_1543257557\build\application\firefox\xul.dll +0x340c865]
19:15:04     INFO - PID 4488 | #16: mozilla_dump_image[Z:\task_1543257557\build\application\firefox\xul.dll +0x3480c99]
19:15:04     INFO - PID 4488 | #17: workerlz4_maxCompressedSize[Z:\task_1543257557\build\application\firefox\xul.dll +0x4a92db8]
19:15:04     INFO - PID 4488 | #18: soundtouch::SoundTouch::operator=[Z:\task_1543257557\build\application\firefox\xul.dll +0x759dd6]
19:15:04     INFO - PID 4488 | #19: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x717561]
19:15:04     INFO - PID 4488 | #20: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x71747c]
19:15:04     INFO - PID 4488 | #21: msgpack_zone_free[Z:\task_1543257557\build\application\firefox\xul.dll +0x71734f]
19:15:04     INFO - PID 4488 | #22: workerlz4_maxCompressedSize[Z:\task_1543257557\build\application\firefox\xul.dll +0x4a924a5]
19:15:04     INFO - PID 4488 | #23: XRE_GetBootstrap[Z:\task_1543257557\build\application\firefox\xul.dll +0x4a9ef91]
19:15:04     INFO - PID 4488 | #24: Ordinal0[Z:\task_1543257557\build\application\firefox\firefox.exe +0x15fd]
19:15:04     INFO - PID 4488 | #25: Ordinal0[Z:\task_1543257557\build\application\firefox\firefox.exe +0x11cd]
19:15:04     INFO - PID 4488 | #26: TargetNtUnmapViewOfSection[Z:\task_1543257557\build\application\firefox\firefox.exe +0x5ebb8]
19:15:04     INFO - PID 4488 | #27: BaseThreadInitThunk[C:\windows\system32\kernel32.dll +0x53c45]
19:15:04     INFO - PID 4488 | #28: RtlInitializeExceptionChain[C:\windows\SYSTEM32\ntdll.dll +0x637f5]
19:15:04     INFO - PID 4488 | #29: RtlInitializeExceptionChain[C:\windows\SYSTEM32\ntdll.dll +0x637c8]
19:15:05     INFO - PID 4488 | ###!!! [Parent][MessageChannel] Error: (msgtype=0x190094,name=PBrowser::Msg_UpdateNativeWindowHandle) Channel error: cannot send/recv
19:15:05     INFO - PID 4488 | ###!!! [Parent][MessageChannel] Error: (msgtype=0x190083,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv
19:15:05     INFO - PID 4488 | ++DOCSHELL 15264400 == 7 [pid = 2644] [id = {9510cfa7-be53-4395-af4e-da234b631b60}]
19:15:05     INFO - PID 4488 | ++DOMWINDOW == 15 (12B56300) [pid = 2644] [serial = 22] [outer = 00000000]
19:15:05     INFO - PID 4488 | ++DOMWINDOW == 16 (1F72A400) [pid = 2644] [serial = 23] [outer = 12B56300]
19:15:05     INFO - PID 4488 | A content process crashed and MOZ_CRASHREPORTER_SHUTDOWN is set, shutting down
19:15:05     INFO - PID 4488 | ++DOMWINDOW == 17 (12A24400) [pid = 2644] [serial = 24] [outer = 12B56300]
19:15:05     INFO - PID 4488 | [Parent 2644, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Parent 2644, Gecko_IOThread] WARNING: file z:/build/build/src/ipc/chromium/src/base/process_util_win.cc, line 188
19:15:05     INFO - PID 4488 | [Child 2736, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Child 2736, Chrome_ChildThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Parent 2644, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Parent 2644, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Parent 2644, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
19:15:05     INFO - PID 4488 | [Parent 2644, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Child 2736, Main Thread] WARNING: NS_ENSURE_TRUE(maybeContext) failed: file z[:/build/build/sPrc/xpcarent 2644, Goecko_IOThrem/threads/nsThread.cpp, lad] WARNING: piine 947
19:15:05     INFO - PID 4488 | pe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Parent 2644, Gecko_IOThread] WARNING: pipe error: 109: file z:/build/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
19:15:05     INFO - PID 4488 | [Parent 2644, Main Thread] WARNING: unable to post continuation event: file z:/build/build/src/xpcom/io/nsStreamUtils.cpp, line 490
19:15:05  WARNING - Traceback (most recent call last):
19:15:05  WARNING -   File "Z:\task_1543257557\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 585, in _run
19:15:05  WARNING -     self.result = True, self.func(self.protocol, self.url, self.timeout)
19:15:05  WARNING -   File "Z:\task_1543257557\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 692, in do_testharness
19:15:05  WARNING -     protocol.base.execute_script(script, async=True)
19:15:05  WARNING -   File "Z:\task_1543257557\build\tests\web-platform\tests\tools\wptrunner\wptrunner\executors\executormarionette.py", line 60, in execute_script
19:15:05  WARNING -     return method(script, new_sandbox=False, sandbox=None)
19:15:05  WARNING -   File "Z:\task_1543257557\build\venv\lib\site-packages\marionette_driver\marionette.py", line 1789, in execute_async_script
19:15:05  WARNING -     rv = self._send_message("WebDriver:ExecuteAsyncScript", body, key="value")
19:15:05  WARNING -   File "Z:\task_1543257557\build\venv\lib\site-packages\marionette_driver\decorators.py", line 26, in _
19:15:05  WARNING -     return func(*args, **kwargs)
19:15:05  WARNING -   File "Z:\task_1543257557\build\venv\lib\site-packages\marionette_driver\marionette.py", line 764, in _send_message
19:15:05  WARNING -     self._handle_error(err)
19:15:05  WARNING -   File "Z:\task_1543257557\build\venv\lib\site-packages\marionette_driver\marionette.py", line 784, in _handle_error
19:15:05  WARNING -     raise errors.lookup(error)(message, stacktrace=stacktrace)
19:15:05  WARNING - NoSuchWindowException: Browsing context has been discarded
19:15:05  WARNING - stacktrace:
19:15:05  WARNING - 	WebDriverError@chrome://marionette/content/error.js:179:5
19:15:05  WARNING - 	NoSuchWindowError@chrome://marionette/content/error.js:411:5
19:15:05  WARNING - 	assert.that/<@chrome://marionette/content/assert.js:418:13
19:15:05  WARNING - 	assert.open@chrome://marionette/content/assert.js:174:10
19:15:05  WARNING - 	GeckoDriver.prototype.execute_@chrome://marionette/content/driver.js:987:3
19:15:05  WARNING - 	async*GeckoDriver.prototype.executeAsyncScript@chrome://marionette/content/driver.js:968:24
19:15:05  WARNING - 	Async*despatch@chrome://marionette/content/server.js:291:20
19:15:05  WARNING - 	async*execute@chrome://marionette/content/server.js:264:11
19:15:05  WARNING - 	async*onPacket/<@chrome://marionette/content/server.js:237:15
19:15:05  WARNING - 	async*onPacket@chrome://marionette/content/server.js:236:8
19:15:05  WARNING - 	_onJSONObjectReady/<@chrome://marionette/content/transport.js:490:9
Status: NEW → RESOLVED
Closed: 11 months ago
Component: web-platform-tests → Graphics
Product: Testing → Core
Resolution: --- → DUPLICATE
Version: Version 3 → unspecified
Duplicate of bug: 1306896
You need to log in before you can comment on or make changes to this bug.