Closed Bug 1510113 Opened 9 months ago Closed 9 months ago

Valgrind leaks in PR_SetEnv and SetWordEnv when nasm is enabled

Categories

(Core :: XPCOM, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox65 --- fixed

People

(Reporter: TD-Linux, Assigned: TD-Linux)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This seems to be caused by LTO decisions changing, which causes different functions to be inlined and the valgrind exceptions to fail.

See: https://treeherder.mozilla.org/logviewer.html#?job_id=213272481&repo=try&lineNumber=45271
This allows Valgrind to recognize the call stacks to this function,
avoiding Valgrind warnings in intentional leaks in these functions.
Assignee: nobody → tdaede
Pushed by tdaede@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d085db32a53d
Never inline SaveToEnv or SaveWordToEnv. r=karlt
https://hg.mozilla.org/mozilla-central/rev/d085db32a53d
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
You need to log in before you can comment on or make changes to this bug.