Cannot add myself to the CC list of a bug if it depends on a bug that I am not authorized to access

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
--
critical
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Alex Bishop, Assigned: myk)

Tracking

Details

(Reporter)

Description

16 years ago
(This may actually belong in mozilla.org/Bugzilla: Other moz.org Issues.)

If I try and add myself to the CC list of a bug which depends on a bug that I am
not authorized to access (e.g. bug 148522 which depends on bug 148520), I get an
error saying "You are not authorized to access bug #148520." (or whatever the
number of the restricted bug is).

Steps to reproduce:
1. Got to bug 148522.
2. Try to add yourself to the CC list.

Expected results:
Get added to the CC list.

Actual results:
The following error appears: "You are not authorized to access bug #148520."
(unless you are actually authorised to access bug 148520 in which case it
presumably works).

I tried adding myself to the CC list of two bugs to test this: bug 148522 (which
depends on bug 148520) and bug 143047 (which depends on bug 125583) - I'm
already on the CC list of the latter bug but I tried adding myself again and got
the error. I assume that this issue would also prevent me from making other
changes to a bug which depends on a restricted bug (though for obvious reasons
I'm reluctant to experiment with this).

I presume this bug was introduced in the upgrade to 2.17.
This would probably be because we try to resolve dependency aliases with the
validation functions....
Blocks: 99203
Depends on: 150783
(Assignee)

Updated

16 years ago
Blocks: 150783
No longer depends on: 150783
bbaetz, justdave, myk: can you remember who made this change? I would try and
track it down, but it strikes me that whoever did it would find it really easy
to fix.

Gerv
I'm guessing that myk did it as part of the alias patch - I don't think that
this is in CVS (although I have't tested)
(Assignee)

Comment 4

16 years ago
This is fixed in the latest version of the patch on bug 99203.
Component: Creating/Changing Bugs → Server Operations
Product: Bugzilla → mozilla.org
Version: 2.17 → other
(Assignee)

Comment 5

16 years ago
The portion of the patch fixing this problem has been applied to b.m.o. 
Resolving fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

16 years ago
I can now add myself to the CC list of bug 148522. Marking VERIFIED FIXED.
Thanks everyone!
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.