Closed Bug 1510182 Opened 11 months ago Closed 11 months ago

Missing context menu items in dev tools

Categories

(DevTools :: General, defect, P2)

65 Branch
defect

Tracking

(firefox65 verified)

VERIFIED FIXED
Firefox 65
Tracking Status
firefox65 --- verified

People

(Reporter: ashu, Assigned: jdescottes)

References

Details

(Whiteboard: [dt-q])

Attachments

(2 files)

Attached video context menu issue.webm
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Steps to reproduce:

1. Inspect element on page
2. Select "Edit As HTML" option
3. In the edit block, select any character and right click on it


Actual results:

Context menu items don't appear


Expected results:

Context menu items should be visible
Component: Untriaged → Inspector
Product: Firefox → DevTools
I can reproduce this issue on OS X. Note: Devtools has to be in dark theme.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Whiteboard: [dt-q]
Component: Inspector → General
Could this be related to Bug 1476097?
Flags: needinfo?(odvarko)
(In reply to Martin Balfanz [:mbalfanz] from comment #1)
> I can reproduce this issue on OS X. Note: Devtools has to be in dark theme.

I can also reproduce in light theme. You have to do "Inspect element" as the first step to reproduce the issue. Opening the inspector and selecting an element in the markup view doesn't trigger it.
Looking into this.
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Complete STRs:

- make sure that the Fonts sidebar panel is selected in the inspector
- open `data:text/html,test`
- right click on `test`, select "Inspect Element"
- in the inspector markup view, right click on the selected element (body) and select "Edit As HTML"
- in the codemirror editor that opens, select a few characters, right click on the selection

=> blank context menu
Blocks: 1476097
"- make sure that the Fonts sidebar panel is selected in the inspector" this is probably wrong, it looks like the issue is more related to trying to open the context menu several times. First time it works. Then it fails. Not sure exactly what is wrong here.
Ok scratch the previous STRs, the issue is that the toolbox-context-menu module only attempts to load the localized strings once. But it should do it every time we get a new window. This module is loaded only once for the whole browser, but the localized strings need to be loaded for every new window created for the toolbox.
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de432b1f84fc
Load edit menu strings for each new toolbox window;r=Honza
https://hg.mozilla.org/mozilla-central/rev/de432b1f84fc
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Status: RESOLVED → VERIFIED
Flags: needinfo?(odvarko)
Flags: qe-verify+
I have reproduced this bug with Nightly 65.0a1 (2018-11-27) on Ubuntu 18.04.1 LTS 64 Bit!
This bug's fix is verified with latest Beta!

Build ID     20181220174318
User Agent   Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0
[bugday-20181219]
(In reply to Mohammad Maruf Rahman from comment #11)
> I have reproduced this bug with Nightly 65.0a1 (2018-11-27) on Ubuntu
> 18.04.1 LTS 64 Bit!
> This bug's fix is verified with latest Beta!
> 
> Build ID     20181220174318
> User Agent   Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101
> Firefox/65.0
> [bugday-20181219]

Please update your browser

Latest beta: 65.0b6 (64-bit)
Latest nightly: 66.0a1

(In reply to Mohammad Maruf Rahman from comment #11)

I have reproduced this bug with Nightly 65.0a1 (2018-11-27) on Ubuntu
18.04.1 LTS 64 Bit!
This bug's fix is verified with latest Beta!

Build ID 20181220174318
User Agent Mozilla/5.0 (X11; Linux x86_64; rv:65.0) Gecko/20100101
Firefox/65.0
[bugday-20181219]

Thanks for verifying this.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.