Default/minimum zoom is really low on pages with wide text

RESOLVED FIXED in Firefox 65

Status

()

enhancement
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: kats, Assigned: hiro)

Tracking

(Blocks 1 bug)

65 Branch
mozilla65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 fixed)

Details

Attachments

(4 attachments)

Loading https://hg.mozilla.org/try/rev/acb07b97fa8ed79112e86e5454b37a3e50593e12 in Fennec renders it quite zoomed out. I don't know if this is expected, haven't really been following all the viewport implementation changes. But in Chrome it doesn't zoom out as much as we do.
Posted image fennec
Posted image Chrome
Assignee

Comment 3

7 months ago
Looks like it comes from the default minimum scale difference.  I will check it.
Flags: needinfo?(hikezoe)
Assignee

Comment 4

7 months ago
Indeed, it is.
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Flags: needinfo?(hikezoe)
Assignee

Comment 5

7 months ago
The reftest in this commit fails without changing the default value.  The test
image is shrunk too much.

Comment 6

7 months ago
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30accf21bb0a
Change the default minimum scale to match Chrome's. r=botond
Landing this has greatly increased gv-junit failures on Android:
https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=gv-junit&tochange=a0315e4606c744555a20bc7e6fc4f3c33bed8463&fromchange=53f6c4e1f112024f662351dd346a966f0fb77f8e

Hiro, can you, please, take a look?
Flags: needinfo?(hikezoe)
Update: retriggers complete, there are gv-junit Perma Failures on this push.
Backed out changeset 30accf21bb0a (Bug 1510214) perma failing org.mozilla.geckoview.test.AccessibilityTest.testScroll

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=gv-junit&tochange=a0315e4606c744555a20bc7e6fc4f3c33bed8463&fromchange=53f6c4e1f112024f662351dd346a966f0fb77f8e&selectedJob=214537605

Backout link: https://hg.mozilla.org/integration/autoland/rev/c302586458e0a418e972652dfc4351380066c319

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=214536674&repo=autoland&lineNumber=1776

[task 2018-11-29T05:00:10.649Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at android.support.test.internal.runner.junit4.statement.RunBefores.evaluate(RunBefores.java:80)
[task 2018-11-29T05:00:10.649Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at android.support.test.internal.runner.junit4.statement.RunAfters.evaluate(RunAfters.java:61)
[task 2018-11-29T05:00:10.649Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1384)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at android.os.Looper.loop(Looper.java:137)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | 	at dalvik.system.NativeStart.main(Native Method)
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test |
[task 2018-11-29T05:00:10.650Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=testScroll
[task 2018-11-29T05:00:10.737Z] 05:00:10     INFO -  org.mozilla.geckoview.test |
[task 2018-11-29T05:00:10.738Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2018-11-29T05:00:10.739Z] 05:00:10  WARNING -  TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.AccessibilityTest.testScroll | status -2
[task 2018-11-29T05:00:10.740Z] 05:00:10     INFO -  TEST-INFO took 125389ms
[task 2018-11-29T05:00:10.740Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2018-11-29T05:00:10.740Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=29
[task 2018-11-29T05:00:10.741Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.ContentDelegateTest
[task 2018-11-29T05:00:10.741Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2018-11-29T05:00:10.742Z] 05:00:10     INFO -  org.mozilla.geckoview.test | org.mozilla.geckoview.test.ContentDelegateTest:
[task 2018-11-29T05:00:10.742Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=224
[task 2018-11-29T05:00:10.742Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=saveAndRestoreState
[task 2018-11-29T05:00:10.743Z] 05:00:10     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: 1
Assignee

Comment 10

7 months ago
OK, setting initial-scale=1 explicitly fixed the failure.  Presumably this change should also fix the failure on Android 7.0 reported in bug 1502087 comment 11.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=081f0127239f7d682fba2f65bbe3b4e007311655&selectedJob=214550863
Flags: needinfo?(hikezoe)

Comment 12

7 months ago
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7d0fd25ddceb
Change the default minimum scale to match Chrome's. r=botond
https://hg.mozilla.org/integration/autoland/rev/17a1195583aa
Set initial-scale=1 to avoid the content elements are placed at unexpected positions. r=eeejay

Comment 13

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7d0fd25ddceb
https://hg.mozilla.org/mozilla-central/rev/17a1195583aa
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Assignee

Updated

7 months ago
Assignee

Updated

7 months ago
Duplicate of this bug: 1313264
You need to log in before you can comment on or make changes to this bug.