Closed Bug 1510511 Opened 11 months ago Closed 11 months ago

Show console separator after the paused message

Categories

(Core :: Web Replay, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1511043

People

(Reporter: bhackett, Assigned: bhackett)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached patch patchSplinter Review
Currently the separator in the console appears before the paused message in the console, instead of after that message where it should be.  I thought this was because the styling for this separator is in .message.paused::before, but changing this to .message.paused::after doesn't change anything.

The attached patch changes the separator to be drawn by setting a style for the message's border-bottom.  This isn't perfect but it is simple; I'm no CSS wizard so let me know if there is a better way to handle this.
Attachment #9028156 - Flags: review?(jlaster)
Thanks. I wasn't sure which was right.

I'm happy to tweak this tomorrow. Here are some quick thoughts. 

- we should show the separation on top of you're payed before the first message. 
- we should use ::before so we don't affect layout and push things down
- we should use a CSS color variable and have some opacity.
This will be fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1511043
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1511043
Attachment #9028156 - Flags: review?(jlaster)
You need to log in before you can comment on or make changes to this bug.