The strings from the "Newsletter" and the "EOY" snippets are not aligned with their checkboxes

VERIFIED FIXED in Firefox 65

Status

()

defect
P2
normal
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: mcoman, Assigned: pdahiya)

Tracking

Trunk
Firefox 66
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox63 unaffected, firefox64 unaffected, firefox65- fixed, firefox66- verified)

Details

Attachments

(4 attachments, 1 obsolete attachment)

Posted image rec of the issue.gif
[Affected versions]:
- Firefox 65.0a1 Build ID - 20181127220131

[Affected Platforms]:
- All Windows
- All Linux
- All Mac

[Prerequisites]:
- Have the latest Firefox Nightly build installed.
- Have a Firefox profile with the following prefs in the "about:config" page:
	- "browser.newtabpage.activity-stream.asrouterExperimentEnabled" with "true" value;

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites.
2. Navigate to "about:config#asrouter" page.
3. Scroll down to the "NEWSLETTER_TEST_1" section and click the "Show" button.
4. Click the "Continue" button and observe the checkbox and its related string from under the email field.

[Expected result]:
- The checkbox and the string are aligned.

[Actual result]:
- The checkbox and the string are not displayed on the same line.

[Additional Notes]:
- This issue is also reproducible with the "EOY" snippets.
- This issue is not reproducible with the latest Firefox Beta build (64.0b13 Build ID - 20181126173133).
- Attached a screen recording of the issue.

Updated

6 months ago
Iteration: --- → 66.1 - Dec 10-23
Priority: -- → P1

Updated

6 months ago
Priority: P1 → P2
Assignee

Updated

6 months ago
Assignee: nobody → pdahiya
Assignee

Comment 1

6 months ago
Failed to replicate issue in latest nightly 66.0a1 -20181211 ( attached screenshot)
Assignee

Comment 2

6 months ago
Hi Marius

Can you please verify if you see the issue in latest nightly. Thanks!
Flags: needinfo?(marius.coman)
Hi,

I have retested this issue with the latest Firefox Nightly build (66.0a1 Build ID - 20181214054322) installed on Windows 10 x64, Arch Linux Arch Linux 4.14.3 and Mac 10.13.3 and it seems that the issue is still reproducible on Windows 10 x64 and Arch Linux and is no longer reproducible on Mac.

Considering this using the Mozregression tool I have managed to find the following regression window:

First good revision: 59ff6b57e94e0d31c8cab5d1f4d92b6aeb0de832
Last bad revision: d8361a515653d512a52024aa05a4d86e68e065a3
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d8361a515653d512a52024aa05a4d86e68e065a3&tochange=59ff6b57e94e0d31c8cab5d1f4d92b6aeb0de832

From the pushlog it seems that this issue was fixed on Mac in Bug 1510766.
Flags: needinfo?(marius.coman)

Comment 5

6 months ago
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/34863855dc6145d73a4dbefc31f14bdd6f233f72
Fix Bug 1510551-Align checkbox with EOY and Newsletter snippet strings (#4594)

Updated

6 months ago
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED

Updated

6 months ago
Blocks: 1515206
Is this something we should consider uplifting to Beta or can it ride the trains?
Flags: needinfo?(pdahiya)
Assignee

Comment 8

6 months ago
We should be uplifting this to Beta, I will submit uplift request. Thanks!
Flags: needinfo?(pdahiya)
Assignee

Comment 9

6 months ago
Hi Marius

Can you please verify this issue is fixed in nightly. This will help to submit uplift request to beta. Thanks!
Flags: needinfo?(marius.coman)
Assignee

Comment 10

6 months ago
Align checkbox with EOY and Newsletter snippet strings
Assignee

Comment 11

6 months ago
Align checkbox with EOY and Newsletter snippet strings
Attachment #9032818 - Attachment is obsolete: true
I have verified that this issue is no longer reproducible with the latest Firefox Nightly (66.0a1 Build ID - 20181220215605) installed, on Windows 10 x64, Arch Linux and Mac 10.13.3. Now, the string is aligned with the checkbox.
Status: RESOLVED → VERIFIED
Flags: needinfo?(marius.coman)
Assignee

Comment 14

6 months ago
Comment on attachment 9032860 [details]
Fix Bug 1510551-Align checkbox with EOY and Newsletter snippet strings r=andreio

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1492086

User impact if declined: Text against checkbox shows misaligned in EOY and newsletter snippets

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: Yes

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): patch has snippets CSS fix

String changes made/needed: none
Attachment #9032860 - Flags: approval-mozilla-beta?
Assignee

Comment 15

6 months ago
[Tracking Requested - why for this release]:
Assignee

Comment 16

6 months ago
Tracking Requested - Better user experience with low hanging UI fixes discovered by QA
Comment on attachment 9032860 [details]
Fix Bug 1510551-Align checkbox with EOY and Newsletter snippet strings r=andreio

[Triage Comment]
UI tweaks for better consistency. Approved for 65.0b7.
Attachment #9032860 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Minor polish issue, doesn't need to be tracked.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.