Closed Bug 1510591 Opened Last year Closed Last year

Try: Decision task breaks when push contains a changeset with an empty commit message

Categories

(Firefox Build System :: Task Configuration, defect)

64 Branch
defect
Not set

Tracking

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 wontfix, firefox65 fixed)

RESOLVED FIXED
mozilla65
Tracking Status
firefox-esr60 --- unaffected
firefox63 --- unaffected
firefox64 --- wontfix
firefox65 --- fixed

People

(Reporter: jlorenzo, Assigned: Callek)

Details

(Keywords: regression)

Attachments

(1 file)

Today, :padenot hit[1] because of this push. This was caused by [3]. I don't have the full context around these changes. Tom, would you mind taking a look at it? 

[1] https://taskcluster-artifacts.net/Gp41N1ujQIaQEh7exSXJBQ/0/public/logs/live_backing.log
[2] https://treeherder.mozilla.org/#/jobs?repo=try&revision=36a75cd5ffd12a6710ab2115b73c3e53277a5123
[3] https://searchfox.org/mozilla-central/diff/dc0ad39bd48520ada43fcfd7d88adf7fec94dc78/taskcluster/taskgraph/files_changed.py#40 (no bug on file)
Flags: needinfo?(mozilla)
Summary: TryL Decision task breaks when push contains a changeset with an empty commit message → Try: Decision task breaks when push contains a changeset with an empty commit message
[task 2018-11-28T13:30:11.261Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/files_changed.py", line 42, in get_changed_files
[task 2018-11-28T13:30:11.261Z]     desc=c['desc'].splitlines()[0].encode('ascii', 'ignore')))
c['desc'].splitlines()[0] raises an error because .splitlines() returns an empty list, rather than a one element list with an empty string when c['desc'] is ''. So test for c['desc'] first and then set it.
Pushed by jwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e1a901cc0a5
Fix 'get_changed_files' to cope with empty commit messages. r=dustin
https://hg.mozilla.org/mozilla-central/rev/4e1a901cc0a5
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
Flags: needinfo?(mozilla)
Assignee: nobody → bugspam.Callek
Keywords: regression
Target Milestone: Firefox 65 → mozilla65
You need to log in before you can comment on or make changes to this bug.