Closed Bug 15108 Opened 21 years ago Closed 19 years ago

UI:Address Book, Visual, General Menu Problems

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 78734
mozilla0.9.2

People

(Reporter: nbaca, Assigned: gerv)

References

()

Details

(Keywords: helpwanted, Whiteboard: ui)

Build 1999092709M11: Win32/NT4
Note: I haven't checked menu items in the Linux or Mac environments yet. This is
a first attempt to report general menu bugs. I've concentrated on menu items,
that are enabled, to see if the Control-Command Keys and Access Keys work. I've
also noted problems with typos, position of an item and removal of an item.

Address Book: Visual

1. File
A. Control-Command Keys
    1. File/New/Message needs "Ctrl+M"

B. Access Keys
    1. "New" needs "N" underlined
    2. "New Card" needs "C" underlined
    3. "Print Preview" needs "v" underlined

C. Change text to state
    1. "Print Card View" shoiuld display as "Print Card"

2. Edit
A. Control-Command Keys
    1. "Delete" should display "Del", not "Ctrl+D"
B. Access Keys
    1. "Preferences" should display first "e" underlined, difficult to tell in
product if "f" or "e" is underlined.

3. View
A. Control-Command Keys, OK
B. Access Keys
    1. View/Sort should have the ability to checkmark an item.
    2. View/Sort should also have the items numbered which each number
underlined.

4. Search
This entire menu item is not displaying.
QA Contact: lchiang → nbaca
QA Contact to nbaca.
Moving to M12
Mass move to M13.
Target Milestone: M13 → M14
M14 since Paul is out sick
Moving to M15.
Target Milestone: M14 → M15
Whiteboard: ui
Mass moving to M17
Target Milestone: M15 → M17
Summary: Address Book: Visual, General Menu Problems → UI:Address Book, Visual, General Menu Problems
Not beta2 stopper. Marking M18.  Add beta2 keyword if you disagree.
Target Milestone: M17 → M18
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW
timeless - another one for you?
sure.
Assignee: putterman → timeless
OS: Windows NT → All
Mass accepting.
Status: NEW → ASSIGNED
Target Milestone: M18 → mozilla0.9
Target Milestone: mozilla0.9 → mozilla0.9.2
Timeless - is it OK if I take this? If that spec is out of date, say so now!

Gerv
spec was created january, listed as last modified february, although i can't 
get lxr to show me versioning past 1.1[initial]
Assignee: timeless → gervase.markham
Status: ASSIGNED → NEW
I think nbaca posted a more recent version of this bug based on the current build.
nbaca: Is this true? :-) Could you point me at the new bug?

Gerv
I apologize.  That isn't true.  There's a Netscape specific bug filed that is
mostly Netscape stuff.  The one issue that fits this bug is 

File|New|Blank Page to Edit needs "Ctrl+Shift+N"

From this current bug, it seems that

1a is fixed
1b seems to be fine or irrelevant
1c is fixed
2 is fixed
3b1 is fixed and I'm not convinced 3b2 is necessary
I'm not sure 4 is necessary in the AB since we currently don't have a search UI
Marking this a duplicate of bug# 78734, which has a more recent status of
changes that need to be made. There is also Bugscape# 4773 which covers Netscape
specific issues.

*** This bug has been marked as a duplicate of 78734 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.