Closed Bug 1510951 Opened Last year Closed Last year

Use ES Classes for protocol.js Actors

Categories

(DevTools :: Framework, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1512153

People

(Reporter: ochameau, Unassigned)

References

(Blocks 1 open bug)

Details

Similarly to bug 1510949, we can switch all Actors to use ES classes.
It should be easier for actors as there should not be any custom overloaded method like protocol.custom/protocol.preEvent that fronts are using.
It will help simplify the inheritance of target actors that are currently relying on extend.
Oops, I just opened a duplicate of this bug...
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1512153
You need to log in before you can comment on or make changes to this bug.