Wrong Clipping on video with webrender

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
major
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: yamadat501, Assigned: kats)

Tracking

(Blocks 1 bug, {regression})

Trunk
mozilla65
Unspecified
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65blocking verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
STR:
1. Enable webrender
2. Open some video (Youtube etc...)
3. Scroll the page

Expected results
Video shows normally any time.

Actual results
(In my case) Left side of video didn't show and clipping area moves while scrolling.

Regression range
autoland
Last OK:74d97073c54b
First NG:1e214baf8fc1

So, caused by Bug 1503447.

Interestingly, in my PC, this problem happens only 64bit version.
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(dmalyshau)
OS: Unspecified → All
Priority: -- → P3
Version: unspecified → Trunk
Priority: P3 → P2
I see this on Reddit pretty easily too.
Actually, I think this should block the Beta65 study rollout.
If I open https://old.reddit.com/r/AnimalsBeingBros/comments/a1gyif/cat_high_fives_runners/, the autoplaying video goes black almost immediately after it starts playing. Reproduces on both 32-bit and 64-bit builds.
We should probably back out the patches from bug 1503447 that are relevant here (1e214baf8fc1 + followups 7d4adeee5236 and f5ffebdcc014)
Duplicate of this bug: 1511081
per comment 3
Priority: P2 → P1
Duplicate of this bug: 1511087
I'll do the backout.
Assignee: nobody → kats

Comment 10

5 months ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9358169404d1
Back out some commits from bug 1503447 for introducing correctness and perf regressions. r=backout
Blocks: 1511024
It would be good to add reftests covering this, if we want the changes to re-land at some point.
Thanks for backout!
Flags: needinfo?(dmalyshau)
Duplicate of this bug: 1511146
Duplicate of this bug: 1511070

Comment 14

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9358169404d1
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65

Updated

5 months ago
Duplicate of this bug: 1511287
Severity: normal → major
this generated a performance improvement

== Change summary for alert #18052 (as of Thu, 06 Dec 2018 08:28:02 GMT) ==

Improvements:

 15%  displaylist_mutate windows10-64-qr opt e10s stylo     4,539.79 -> 3,860.38

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=18052
And brought back at least one Raptor baseline:

== Change summary for alert #17949 (as of Fri, 30 Nov 2018 01:16:57 GMT) ==

Improvements:

  2%  raptor-motionmark-htmlsuite-firefox opt      56.24 -> 57.63

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=17949
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.